MozillaPL.org - polskie centrum Mozilli

Główne menu:

Dodatki Przestarzałe

Dodatki rozszerzające funkcjonalność i schematy wyglądu Mozilli Firefox

Moderator: Pomocy?!

Dodatki Przestarzałe

Postautor: Gie » 10 sierpnia 2017, 13:30

Przeglądarka: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0

Zaktualizowałem FF do 55. Wszystko działa OK. Chciałem sobie przetłumaczyć fragment tekstu przy użyciu Słowniczka i pod prawym klawiszem nie ma odpowiedniej funkcji. Wchodzę w dodatki a tam praktycznie przy każdym dopisek - Przestarzałe. Rzuciłem okiem w siec i czy to oznacza że od FF 57 nie uruchomimy tych dodatków? Nie będzie jakiegoś myku? Czy dla twórców przejście na nowy standard jest skomplikowane? Szczerze mówiąc siedzę na FF tylko i wyłącznie z powodu kilku dodatków których nie udało mi się znaleźć np. na Chrome. Gdyby przestały działać to opuszczam FF będę musiał się przyzwyczaić do Chrome.
Ostatnio zmieniony 10 sierpnia 2017, 17:59 przez Gie, łącznie zmieniany 1 raz
Gie
 
Posty: 176
Z nami od: 06 listopada 2006, 09:13

Odp: Dodatki Przestarzałe

Postautor: dexter » 10 sierpnia 2017, 14:05

Przeglądarka: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

1. Tak, od 57 nie uruchomimy tych dodatków.

2. Może będzie jakiś myk, no ale jednak najlepiej byłoby, gdyby dodatki przepisać na nowe API.

3. Czy to skomplikowane? No raczej nie bardzo, ale z lenistwa część developerów tego nie zrobi, ja zamierzam tylko 1 ze swoich wszystkich trzech przepisać, bo jest mi potrzebny (ale póki co na Nocnej działa, więc mi się nie chce). Plusem jest kompatybilność z innymi przeglądarkami. Minusem, że póki co to API jest dość ograniczone.

4. Nadal dodatki w Firefoksie będą mogły więcej, niż chromowe, np. uBock origin.
dexter
Moderator
 
Posty: 6976
Z nami od: 02 października 2004, 21:30

Odp: Dodatki Przestarzałe

Postautor: _Puma_ » 10 sierpnia 2017, 15:06

Przeglądarka: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

Ja powoli szukam nowszych dodatków ale z tego co widzę to niestety sporo nie zostanie zaktualizowany.
Obecnie połowę dodatków mam nowych a że używam wersji Firefox beta to nie mam aż tak dużo czasu.
_Puma_
 
Posty: 549
Z nami od: 31 października 2005, 19:34

Odp: Dodatki Przestarzałe

Postautor: beata072 » 10 sierpnia 2017, 17:30

Przeglądarka: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:49.0) Gecko/20100101 Firefox/49.0

To do której wersji jeszcze można korzystać z dotychczasowych dodatków? Już teraz muszę korzystać ze sposobu podanego tutaj: viewtopic.php?f=15&t=48500#p235707 - czy na v.55 to jeszcze działa? I czy w ogóle warto zmieniać na v.55, czy ta wersja będzie w czymś lepsza dla zwykłego użytkownika? Mam bardzo dużo dodatków, więc pewnie z tej wielowątkowości czy jak to się tam zwie i tak nie skorzystam, więc nie wiem, czy jakąś zmianę w szybkości zauważę. A jeśli nie w szybkości, to w czym 55 jest lepsze od 49 (poza ew. bezpieczeństwem), ktoś się orientuje? W tej chwili miewam problemy z Gmail (czasami się wiesza), YT (komentarze długo się ładują) i FB (topornie się przewija). Nie wiem czy jest szansa, że coś z tymi stronami będzie lepiej na v.55 pomimo dużej ilości dodatków, z których zapewne spora część będzie przestarzała...
beata072
 
Posty: 916
Z nami od: 27 lutego 2010, 04:18

Odp: Dodatki Przestarzałe

Postautor: dexter » 10 sierpnia 2017, 19:02

Przeglądarka: Mozilla/5.0 (Windows NT 6.0; rv:52.0) Gecko/20100101 Firefox/52.0

1. Wersja 56 będzie ostatnia dla starych dodatków.

2. Ten sposób - czyli chodzi o uruchomienie niepodpisanych dodatków - raczej powinien do 56 działać.

3. Ta wersja 55 jest ogólnie bardzo chwalona. Jak masz dużo kart w sesji, na pewno zauważysz szybkość uruchamiania. FB będzie lepiej działał, z powodu Intersection Observer.

4. Myślę, że zauważysz zmiany na plus.

5. Aha, jeszcze z tej wersji nie można się cofnąć poniżej 53. Lepiej zrób kopię profilu przed update'em.
dexter
Moderator
 
Posty: 6976
Z nami od: 02 października 2004, 21:30

Odp: Dodatki Przestarzałe

Postautor: beata072 » 10 sierpnia 2017, 19:05

Przeglądarka: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:49.0) Gecko/20100101 Firefox/49.0

Dziękuję za wyczerpującą odpowiedź :)
beata072
 
Posty: 916
Z nami od: 27 lutego 2010, 04:18

Odp: Dodatki Przestarzałe

Postautor: beata072 » 11 sierpnia 2017, 21:50

Przeglądarka: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0

Zainstalowałam wersję 55 i coś się skaszaniło z działaniem dodatku Flash Control. Kiedy jest włączony, to w ogóle nie działają mi filmy na YT, wyświetla się komunikat o błędzie. Dopiero gdy ustawię, aby na YT Flash Control był wyłączony, wszystko wraca do normy. Tylko, że ja nie chcę, aby mi filmy na YT startowały automatycznie :(
Przy dodatku mam żółty komunikat "Przestarzały", tak jak i przy 99% wszystkich pozostałych. Tylko przy jednym nie ma tego komunikatu.
beata072
 
Posty: 916
Z nami od: 27 lutego 2010, 04:18

Odp: Dodatki Przestarzałe

Postautor: Garu » 11 sierpnia 2017, 22:53

Przeglądarka: Mozilla/5.0 (Windows NT 5.1; rv:50.0) Gecko/20100101 Firefox/50.0

Zastanawiam się, czy na FF55 pójdzie to: https://www.chromeactions.com/
Wybiera się firefoxa, potem ustawia jakość, potem ukryj reklamy, wybór odtwarzacza, wyłączenie autoplay i speed booster. Nawet ultra HD śmiga.
Flash control, to robi interakcje z wtyczkami adobe i często są problemy. Magik z kolei załatwia wszystkie problemy z YT i daje multum satysfakcji, nawet tryby kinowe itd.
Nie liczyłbym na to, że Firefox naprawi system.
Garu
 
Posty: 978
Z nami od: 31 stycznia 2014, 18:55

Odp: Dodatki Przestarzałe

Postautor: beata072 » 11 sierpnia 2017, 23:32

Przeglądarka: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0

Wybór odtwarzacza? A to działa na wszystkich stronach na których jest wstawione jakieś video? Bo Flash Control to mam głównie po to, aby mi się nie uruchamiały filmiki na różnych stronach, nie tylko na YT. No i jeszcze używam YouTube HD. Nie wiem, czy to wszystko się nie pokłóci ze sobą. Chyba przetestuję tego Magika na nowym profilu. Jeśli będzie działać na innych stronach i z automatu ustawiać jakość 720p (jeśli dostępna), to mógłby mi zastąpić te 2 dodatki.
beata072
 
Posty: 916
Z nami od: 27 lutego 2010, 04:18

Odp: Dodatki Przestarzałe

Postautor: Garu » 11 sierpnia 2017, 23:50

Przeglądarka: Mozilla/5.0 (Windows NT 5.1; rv:50.0) Gecko/20100101 Firefox/50.0

Rozumiem o co chodzi. Domyślny odtwarzasz na YT, to html5, albo flash. W magic action jest opcja wyboru.
Magic możesz ustawić na 1080p domyślnie. https://images84.fotosik.pl/743/536087821d09a69c.png
Pod filmem są opcje magika.
Nie liczyłbym na to, że Firefox naprawi system.
Garu
 
Posty: 978
Z nami od: 31 stycznia 2014, 18:55

Odp: Dodatki Przestarzałe

Postautor: beata072 » 11 sierpnia 2017, 23:54

Przeglądarka: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0

Oki, potestuję sobie, dzięki :)

@Edycja:
Zainstalowałam, dodatek wydaje się kompatybilny z tą wersją FF. Niestety pomimo zaznaczenia opcji "Stop Autoplay" na str.: https://www.chromeactions.com/magic-options.html, filmy nadal startują automatycznie :(
Ogólnie te opcje jakoś dziwnie się zachowują. Początkowo w ogóle nic nie dało się tam zaznaczyć czy odznaczyć. Dopiero po restarcie zaskoczyło, ale np. przycisk eksportu ustawień nadal nie reaguje. Przed restartem miałam ikonkę Magic na pasku nawigacji, a teraz jej nie mam. Był też jakiś dziwny przycisk na stronie YT po lewej przy hamburgermenu, a teraz go tam nie ma. Tak jakby dodatek przestał działać? Nie wiem o co chodzi...

@Edycja2:
Po kolejnym restarcie ikonka powróciła, ale przycisk już nie. Do tego dla odmiany ustawienia na stronie https://www.chromeactions.com/magic-options.html znów są nieaktywne.
Zainstalowałam go również na Chrome i tam normalnie działa. Wygląda więc, że to z FF ma problem, albo z jakimiś dodatkami, bo skopiowałam profil i tylko wyłączyłam Fresh Control oraz YouTube HD. Nie chciałam sprawdzać na całkiem czystym profilu, bo i tak przecież potrzebuję tych wszystkich dodatków.
beata072
 
Posty: 916
Z nami od: 27 lutego 2010, 04:18

Odp: Dodatki Przestarzałe

Postautor: beata072 » 12 sierpnia 2017, 03:34

Przeglądarka: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0

Nie mogę edytować poprzedniego posta, jakiś błąd ogólny się wyświetla, więc dopisuję w nowym.
Okazuje się, że jednak na Chrome też nie działa idealnie, bo np. zaznaczyłam Comments Features: Newest first, a i tak miałam od najlepszych. Jednak Stop Autoplay oraz wybór jakości zadziałał.
I jednak sprawdziłam także na całkiem czystym profilu FF, gdzie okazało się że działa, a więc to jakieś dodatki powodują problem. Niestety sprawdzanie które konkretnie, byłoby bardzo uciążliwe.
Bardzo mnie martwi ten problem z Flash Control, ponieważ blokował autostart praktycznie na każdej stronie, zarówno HTML5 jaki i flash.

@Edycja:
Udało mi się w końcu zablokować autostart filmów na YT za pomocą dodatku YouTube HD. Tzn. wiedziałam, że ma on taką opcję, ale wydawała się nie działać. Dopiero po zmianie w about:config extensions.youtubehighdefinition.enableautoplay na false zadziałało. Tak więc na YT mogę mieć Flash Control wyłączony i mieć nadzieję, że na innych stronach nie będzie powodować problemów. Na jednej już sprawdzałam i działa jak dawniej.
beata072
 
Posty: 916
Z nami od: 27 lutego 2010, 04:18

Odp: Dodatki Przestarzałe

Postautor: dexter » 12 sierpnia 2017, 18:23

Przeglądarka: Mozilla/5.0 (Windows NT 6.0; rv:52.0) Gecko/20100101 Firefox/52.0

Na ghacks.net napisali, że pojawiła się opcja do włączenia starych rozszerzeń, ale działa tylko w Nocnej.
dexter
Moderator
 
Posty: 6976
Z nami od: 02 października 2004, 21:30

Odp: Dodatki Przestarzałe

Postautor: beata072 » 12 sierpnia 2017, 18:27

Przeglądarka: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0

Tzn. ja te rozszerzenia mam włączone i one działają, tylko wygląda, że niektóre nie do końca prawidłowo.
beata072
 
Posty: 916
Z nami od: 27 lutego 2010, 04:18

Odp: Dodatki Przestarzałe

Postautor: beata072 » 12 sierpnia 2017, 22:15

Przeglądarka: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0

Esz, kolejny problem się objawił. Nie mam dźwięku czatu na jednej stronie :( No i tak to właśnie wygląda. Jak człowiek już się zdecyduje na aktualizację, to zawsze coś się zepsuje i trzeba stracić mnóstwo czasu, aby to naprawić :(
beata072
 
Posty: 916
Z nami od: 27 lutego 2010, 04:18

Odp: Dodatki Przestarzałe

Postautor: marcinooo » 13 sierpnia 2017, 07:51

Przeglądarka: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:55.0) Gecko/20100101 Firefox/8090

I właśnie w celu wyeliminowania takich niekończących się problemów jak u niektórych użytkowników tutaj, wprowadzono całą tę nową technologię dodatków dla Firefoksa. Wprowadzenie tej nowej technologii można porównać do zastrzyku, jesteśmy u lekarza/pielęgniarki, który ma w ręku strzykawkę z igłą i chce nam zrobić zastrzyk w pośladek (bo jesteśmy chorzy albo np. szczepionkę), a wiadomo każdy boi się igły, więc sobie myślimy, ale to wszystko straszne i niektórym ciarki przechodzą, ale to dla naszego dobra, dzięki zastrzykowi/szczepionce będziemy mieli mniej problemów z chorobami / będziemy chorować rzadziej w przyszłości co się tłumaczy na = będzie mniej zgrzytów na linii przeglądarka - dodatek, w szczególności po aktualizacji przeglądarki. Do tej pory problem był taki, że wcześniej dodatek mógł sobie pozwolić na zbyt dużo, czyli tak mocno integrował się / wgryzał się we wszystkie miejsca przeglądarki - w jej kod źródłowy, że później gdzie by czegoś nie zmienić/zaktualizować w przeglądarce i wypuścić jej nową wersję, to były często to właśnie te miejsca gdzie wgryzł się wcześniej dodatek, w związku z czym, dodatek zaczynał szwankować, często pociągając za sobą przeglądarkę, co się objawiało wszelkiej maści problemami, od najmniejszych (coś w dodatku/przeglądarce zaczyna działać źle/ lub w ogóle przestaje działać) do najbardziej poważnych (przeglądarka/dodatek powodują zawieszenia, zacinanie, wyświetlanie stron, uniemożliwiając komfortową pracę). W nowej technologii dodatków (WebExtensions) uprawnienia dodatków zostały ograniczone, przez co dodatki już nie mogą tak mocno wgryzać się/splątywać się z przeglądarką, po prostu dodatki nie będą już tak mocno zależne od przeglądarki, dzięki czemu przy aktualizacji przeglądarki nie będzie tylu problemów na linii przeglądarka - dodatek. Oczywiście nie ma róży bez kolców, więc ograniczenie dodatkom ingerencji w przeglądarkę oznacza również mniejszą funkcjonalność dodatków, bo będą mogły mniej. No ale nie można zjeść ciastka i mieć ciastka, więc musi być jakiś kompromis pomiędzy stablinością, a funkcjonalnością i właśnie o takim kompromisie zadecydowała Mozilla:
https://support.mozilla.org/pl/kb/moder ... -firefoksa
https://arewewebextensionsyet.com/ (tu można podejrzeć stan uaktualniana dodatków do nowej technologi)

Gwoli pewnego sprostowania, etykieta "Przestarzałe" nie oznacza, że dodatek nie będzie działał w FF 57+, co błędnie stwierdził dexter, a oznacza jedynie, że dodatek na chwilę obecną nie zadziałałby z FF 57+, bo twórcy mogą być w trakcie uaktualniania dodatku i do czasu wyjścia FF 57, dodatek może stać się kompatybilny z FF 57 (zniknie etykieta "Przestarzały") i zadziała z FF 57, co nie zmienia oczywiście faktu, że nie wszystkie dodatki zostaną uaktualnione, i z częścią trzeba będzie się pożegnać.

Podobnie jak z dodatkami było z wtyczkami typu Flash, Java, Silverlight, również powodowały zbyt dużo problemów, dlatego również zostały zastąpione nowszą technologią, czyli tą zaszytą w HTML5. A więc wszystko co "złe" to dla naszego dobra, żeby było mniej problemów, żeby chodziła szybciej i nie zawieszała / zacinała się i nie muliła. A jak to się wszystko będzie wyglądało w praktyce niebawem się przekonamy.
marcinooo
 

Odp: Dodatki Przestarzałe

Postautor: _Puma_ » 13 sierpnia 2017, 10:49

Przeglądarka: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

W Firefox 57 wszystkie rozszerzenia oznaczone jako przestarzałe zostały wyłączone.
W Firefox 55 i 56 dane rozszerzenia jeszcze działają.

Sprawdziłem wszystkie wersje tzn. Stable, Beta i Night.
_Puma_
 
Posty: 549
Z nami od: 31 października 2005, 19:34

Odp: Dodatki Przestarzałe

Postautor: Gie » 15 sierpnia 2017, 08:19

Przeglądarka: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0

No nie tak do końca na FF 55 działają. Niby są ale jakby ich nie było. Download Status Bar niby działa jak należy a są problemy z usunięcie paska po pobranym pliku. Image Toolbar pojawia się na obrazku ale po kliknięciu w ikonkę zapisz nic się nie dzieje. To tylko kilka przykładów z moich dodatków.
Gie
 
Posty: 176
Z nami od: 06 listopada 2006, 09:13

Odp: Dodatki Przestarzałe

Postautor: Garu » 15 sierpnia 2017, 10:46

Przeglądarka: Mozilla/5.0 (Windows NT 5.1; rv:50.0) Gecko/20100101 Firefox/50.0

FF55 szybszy, ale nie lżejszy. Wrzuciłem na laptopie, żeby zaktualizować FF49, a on się zainstalował osobno x64, do tego piorunem, jak wirus. No ale. Tylko rozszerzenie disconnect pasowało mu, a moje wszystkie mają czerwony stempel, że przestarzałe, nawet, gdy pisało przy paru, żeby zaktualizować, to zaktualizowałem, ale i tak są przestarzałe.

Wychodzi na to i na tamto, że teraz trzeba będzie korzystać z zewnętrznych programów, żeby choć po części mieć to, co oferowały dotąd rozszerzenia. Trafiło mnie, dobił container.
Nowy firefox nie obsługuje wielu czcionek systemowych. A to dla mnie dyskwalifikacja. Specy mozilli wciąż dają wybrakowany produkt w kwestii niedostosowania wyglądu do stopni powiększania elementów w systemie, chodzi o personalizację, zaawansowane opcje wyglądu, czyli okna, menu i tam takich a wszędzie rozmiar i rodzaj czcionek.
Przy pewnych powiększeniach po prostu okienka opcji są ucięte w połowie. Przykładowo okienko ustawienie czyszczenia historii. To zaczęło się od dnia, gdy opcje zaczęły otwierać się w nowych kartach.
Muszę grzebać w systemie, zmniejszać czcionki i z lupą ustawiać firefoxa, bo jestem słabowidzący. Potem znów grzebać w systemie, żeby ustawiać tak, żeby firefox był czytelny.
Dla mnie, to szok. Przechodzę na XP, żeby normalnie ze wszystkiego korzystać. Na laptopie, to ie11 bierze średnio 88MB RAM. Mam blokownie reklam adfenderem, parę aplikacji portable, w tym do pobierania plików i filmów. Do tego ie11 chodzi piorunem, a FF55, to czołg, ale ma przydatne funkcje. Szybsza od downthemall jest slimjet portable.
Mozilla, ech, tylko kroi i resztę unowocześnia, a nowe funkcje eksperymentalne, to malware, szpiegostwo i...
Nie liczyłbym na to, że Firefox naprawi system.
Garu
 
Posty: 978
Z nami od: 31 stycznia 2014, 18:55

Odp: Dodatki Przestarzałe

Postautor: Gość » 19 sierpnia 2017, 19:45

Przeglądarka: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0

Rozszerzenie All-in-One Sidebar zakończy swój żywot na ff57.

https://www.ghacks.net/2017/08/17/all-i ... ox-add-on/
Gość
 


Wróć do Rozszerzenia dla Firefoksa

Kto jest online

Zarejestrowani użytkownicy: Bing [Bot], Google [Bot], Yahoo [Bot]

Przejdź do powiązanej strony

Nawigacja:

Stopka: