MozillaPL.org - polskie centrum Mozilli

Główne menu:

brak panelu kontrolnego osadzonego pliku audio

Jak tworzyć strony WWW zgodnie ze standardami

Moderator: Pomocy?!

brak panelu kontrolnego osadzonego pliku audio

Postautor: kuszelas » 13 lipca 2013, 13:58

Przeglądarka: Mozilla/5.0 (Windows NT 5.1; rv:22.0) Gecko/20100101 Firefox/22.0

Witam,
W trakcie nauki budowania własnej www, postanowiłem na niej osadzić plik audio.
Skorzystałem z takiego skryptu:
<object ID="MediaPlayer1" width=280 height=45
classid="CLSID:22D6F312-B0F6-11D0-94AB-0080C74C7E95"
codebase="
http://activex.microsoft.com/activex/co ... 6,0,02,902"
standby="Loading Microsoft® Windows® Media Player components..."
type="application/x-oleobject">
<param NAME="FileName" VALUE="audio.mp3">
<param NAME="animationatStart" VALUE="true">
<param NAME="transparentatStart" VALUE="true">
<param NAME="autoStart" VALUE="true">
<param NAME="showControls" VALUE="true">
<param name="Volume" value="0">
<embed type="application/x-mplayer2"
pluginspage =" http://www.microsoft.com/Windows/MediaPlayer/"
SRC="audio.mp3"
name="MediaPlayer1"
width=300
height=40
AutoStart=true>
</embed>
Ten skrypt działa w pełni poprawnie w Internet Explorerze 8.
Natomiast W FF (v.22.0) po otwarciu strony, w miejscu gdzie powinien pojawić się panel kontrolny, widnieje tylko "pusty" biały prostokąt o wymiarach 300x40.
Wygląda to tak:
Obrazek<br>
Ale wykonując jedną z przykładowych poniższych czynności:
-kliknięcie na przycisk: "minimalizuj" i powrót z tego stanu
-otwarcie na nowej karcie dowolnej strony www i ponowny powrót do własnej
powoduje pojawienie się w panelu kontrolnego w należnym miejscu i pełnej jego funkcjonalności.
I wygląda to tak:
Obrazek

Proszę o radę, co mam wykonać, aby panel ten pojawiał się przy otwarciu strony, bez dodatkowych kombinacji "wymuszających".
Pozdrawiam
mk
kuszelas
 
Posty: 43
Z nami od: 04 kwietnia 2011, 20:12

Odp: brak panelu kontrolnego osadzonego pliku audio

Postautor: dexter » 13 lipca 2013, 15:17

Przeglądarka: Mozilla/5.0 (Windows NT 6.0; rv:24.0) Gecko/20130701 Firefox/24.0

A tak nie działa? Warunkiem jest poprawna ścieżka do pliku:

Kod: Zaznacz cały
<!DOCTYPE html>
<html lang="en">
<head>
  <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
  <title>test: audio tag</title>

</head>
<body>

<div class="resultObject">
<audio src="test.mp3" controls autoplay loop>
<p>Your browser does not support the audio element </p>
</audio>
</div>
</body>
</html>
dexter
Moderator
 
Posty: 7369
Z nami od: 02 października 2004, 21:30

Odp: brak panelu kontrolnego osadzonego pliku audio

Postautor: kuszelas » 13 lipca 2013, 17:12

Przeglądarka: Mozilla/5.0 (Windows NT 5.1; rv:22.0) Gecko/20100101 Firefox/22.0

Niestety.
Ścieżkę do pliku podałem poprawnie taką, jaką mam zapisaną w przesłanym skrypcie, który działa po "wymuszeniu".
W przypadku tego skryptu, panel kontrolny pojawia się na moment i znika. Po kilkukrotnym odświeżeniu jest już widoczny na stałe, ale nie da się na nim wymusić odtwarzania, mimo że kliknięcie na trójkącik: "odtwórz", zmienia go na: "zatrzymaj".
Poza tym, ja swoją stronę, ucząc się, pisałem w HTML, a Twój DOCTYPE chyba dotyczy HTML5.
Wydaje mi się, że jakbym zastosował ten typ dokumentu do mojej strony, prawdopodobnie całkowicie by mi się "rozkraczyła".
Mój DOCTYPE wygląda tak:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
Gdybyś mógł wymyślić coś do niego ?
Wydaje mi się, że jeżeli IE odczytuje kod prawidłowo, a FF prawie że prawidłowo, to może jakaś zmiana ustawień FF ????
Gdy zastosowałem taki kod:
<embed width="300" height="35" loop="true" autostart="false" controller="true" target="myself" src="http://www.markotar.p.ht/multimedia/melody.mp3" type="video/quicktime" bgcolor="#000000" BORDER="0" pluginspage="http://www.apple.com/quicktime/download/indext.html"></embed>
FF odczytał go prawidłowo. Panel jest widoczny. Tylko, że ja mam zainstalowany odtwarzacz VLC, który posiada plugin Quicktime'a...., bo w przeciwnym razie przeglądarka woła o zainstalowanie odtwarzacz QuickTime.

edycja:19:55
Wydaje się, że sytuacja jest opanowana. Na razie jest OK.
Niestety, na podstawie moich danych, nikt nie miał prawa zdiagnozować usterki, ponieważ błąd tkwił poza skryptem.
Otóż, chcąc ustawić sobie na stronie ten panel kontrolny na środku, zastosowałem polecenie: <div align="center> ....skrypt........</div>
Polecenie to znałem z mojego starego podręcznika: HTML-kurs podstawowy.
Obecnie tak nowoczesna przeglądarka, jak FF, nie rozpoznaje prawidłowo tego przestarzałego znacznika (IE jeszcze go rozpoznaje i toleruje).
Nie wiem, czy zrobiłem fachowo, ale po zmianie <div align="center"> na <center> skrypt na razie działa OK.
Dzięki za zainteresowanie tematem i Sorki za zamieszanie spowodowane moim błędem.
Pozdrówka
mk
edycja: 21:10
Niestety za wcześnie odtrąbiłem sukces. Wszystko wróciło no normy, czyli jest kiepsko. Panel kontrolny pojawia się wyłącznie po takich kombinacjach z klikaniem, jakie opisałem wcześniej.
Ostatnio zmieniony 13 lipca 2013, 20:19 przez kuszelas, łącznie zmieniany 1 raz
kuszelas
 
Posty: 43
Z nami od: 04 kwietnia 2011, 20:12

Odp: brak panelu kontrolnego osadzonego pliku audio

Postautor: dexter » 13 lipca 2013, 21:12

Przeglądarka: Mozilla/5.0 (Windows NT 6.0; rv:24.0) Gecko/20130701 Firefox/24.0

Być może ten błąd ma z tym coś wspólnego: https://bugzilla.mozilla.org/show_bug.cgi?id=890516
dexter
Moderator
 
Posty: 7369
Z nami od: 02 października 2004, 21:30

Odp: brak panelu kontrolnego osadzonego pliku audio

Postautor: kuszelas » 15 lipca 2013, 13:56

Przeglądarka: Mozilla/5.0 (Windows NT 5.1; rv:22.0) Gecko/20100101 Firefox/22.0

Dzięki za pomocne wskazówki.
Będzie mnie to kosztowało jeszcze sporo pracy, ponieważ poniższy kod:

<object ID="MediaPlayer1" width=300 height=44
classid="CLSID:22D6F312-B0F6-11D0-94AB-0080C74C7E95"
codebase="http://activex.microsoft.com/activex/controls/mplayer/en/nsmp2inf.cab#version=6,0,02,902"
standby="Loading Microsoft Windows Media Player components..."
type="application/x-oleobject">
<param NAME="FileName" VALUE="multimedia/plikaudio.mp3">
<param NAME="autoStart" VALUE="0">
<param NAME="showControls" VALUE="true">
<param NAME="Volume" VALUE="0">
<embed type="application/x-mplayer2"
pluginspage ="http://www.microsoft.com/Windows/MediaPlayer/"
SRC="http://markotar.prv.pl/multimedia/plikaudio.mp3"
name="MediaPlayer1"
width=300
height=44 align="center" vspace="5" hspace="5"
AutoStart="0">
</embed>
</object>

na jednej z podstron działa prawidłowo, natomiast na drugiej - kiepsko (Zamiast panelu kontrolnego, wyświetlany jest biały prostokącik o wymiarach podanych w skrypcie. Pojawienie się panelu w tym prostokąciku następuje kiedy kliknę na "zminimalizuj", a następnie przywrócę poleceniem "przywróć").
Wobec tego, poddałem tę podstronę walidacji zgodnie z zaleceniami z Waszego forum (viewtopic.php?t=13419).
Sporo błędów. Również na podstronie, która działa prawidłowo, ale widocznie mniej krytyczne, bo FF je toleruje.
Tak więc po poprawieniu tych błędów, efekt MUSI być.
Pozdrawiam
mk
kuszelas
 
Posty: 43
Z nami od: 04 kwietnia 2011, 20:12


Wróć do Tworzenie stron WWW

Kto jest online

Zarejestrowani użytkownicy: Bing [Bot], dexter, fbarraza, ff2017

Przejdź do powiązanej strony

Nawigacja:

Stopka: