MozillaPL.org - polskie centrum Mozilli

Główne menu:

Nieprawidłowe czcionki - brak polskich liter w wiadomościach

Tematy specyficzne dla klienta poczty Mozilla Thunderbird

Moderator: Pomocy?!

Nieprawidłowe czcionki - brak polskich liter w wiadomościach

Postautor: addos » 05 grudnia 2009, 11:46

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 6.1; pl; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5

Posiadam Thunderbirda w wersja 2.0.0.23 (20090812). Problem polega na błędnym wyświetlaniu czcionek w wiadomościach ( podgląd w odnośniku http://img268.imageshack.us/img268/8264 ... rbirdc.jpg ). Problem pojawił się jakiś czas temu i żadna nowa wersja programu nie poprawiła wyświetlania wiadomości. Ustawienie czcionki jest domyślne, ręcznie przestawianie nie poprawiło wyświetlania. Formatowanie systemu nie pomaga po importowaniu wiadomości za pomocą mozupdate problem się ponawia.

// Przykleiłem temat, może dzięki temu więcej osób z niego skorzysta - Grzegorz.
// Przejdź do postu z >>rozwiązaniem<< problemu.
addos
 
Posty: 2
Z nami od: 05 grudnia 2009, 11:04

Odp: thunderbird wyświetlanie czcionek

Postautor: Grzegorz » 05 grudnia 2009, 12:08

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091204 Minefield/3.7a1pre

Wygląda na problem z kodowanie znaków lub wykrywaniem zastosowanego kodowania. Zmienisz je w Thunderbirdzie w menu Widok > Zestaw znaków > tutaj wypróbuj UTF, środkowoeuropejski ISO oraz Windows-1250.
GnuPG. Podpisuję własne wypowiedzi. | TrueCrypt. Ufam kryptografii, nie państwu. | Tor. Dbam o swoją prywatność. | OTR. Moje rozmowy nie są podsłuchiwane.

Załóż konto lub kup domenę WWW z linka polecającego: http://www.hekko.pl/?ref=34295
Grzegorz
Moderator
 
Posty: 7466
Z nami od: 15 kwietnia 2007, 12:33

Odp: thunderbird wyświetlanie czcionek

Postautor: addos » 06 grudnia 2009, 09:20

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 6.1; pl; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5

Po zmianie na UTF, Środkowoeuropejski ISO nie ma zmian po zmianie na windows-1250 znikają czarne pola z znakiem ? ale reszta zostaje bez zmian i zauważyłem że 1 z 15 wiadomości jest wyswietlana prawidłowo przy ustawieniach domyslnych
addos
 
Posty: 2
Z nami od: 05 grudnia 2009, 11:04

Odp: thunderbird wyświetlanie czcionek

Postautor: Grzegorz » 06 grudnia 2009, 13:06

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091204 Minefield/3.7a1pre

A w przeglądarce internetowej, jak wygląda sprawa po zalogowaniu się do webmaila? Jeśli ta poczta jest przekazywana (i serwer lub program przekazujący niepoprawnie koduje znaki) to może dochodzić do opisywane sytuacji, a poprawnie wyświetlanych polskich znaków nie będzie się dało przywrócić bez edycji wiadomości.
GnuPG. Podpisuję własne wypowiedzi. | TrueCrypt. Ufam kryptografii, nie państwu. | Tor. Dbam o swoją prywatność. | OTR. Moje rozmowy nie są podsłuchiwane.

Załóż konto lub kup domenę WWW z linka polecającego: http://www.hekko.pl/?ref=34295
Grzegorz
Moderator
 
Posty: 7466
Z nami od: 15 kwietnia 2007, 12:33

Odp: thunderbird wyświetlanie czcionek

Postautor: EvilZara » 10 grudnia 2009, 19:12

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)

Witam mam ten sam problem z kodowaniem w wersji 3.0, czy ktoś wie jak to rozwiązać ?
EvilZara
 

Odp: thunderbird wyświetlanie czcionek

Postautor: mr.Dark » 28 grudnia 2009, 16:45

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6 (.NET CLR 3.5.30729)

Opcje -> zaawansowane -> edytor ustawień:
mailnews.force_charset_override -> false
mr.Dark
 

Odp: Nieprawidłowe czcionki - brak polskich liter w wiadomoś

Postautor: Grzegorz » 08 stycznia 2010, 11:37

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20100106 Minefield/3.7a1pre

Najlepsze w tym wszystkim jest to, że kilka osób potwierdziło, że to rozwiązanie działa - a przecież mailnews.force_charset_override = false jest ustawieniem domyślnym!
GnuPG. Podpisuję własne wypowiedzi. | TrueCrypt. Ufam kryptografii, nie państwu. | Tor. Dbam o swoją prywatność. | OTR. Moje rozmowy nie są podsłuchiwane.

Załóż konto lub kup domenę WWW z linka polecającego: http://www.hekko.pl/?ref=34295
Grzegorz
Moderator
 
Posty: 7466
Z nami od: 15 kwietnia 2007, 12:33

Odp: Nieprawidłowe czcionki - brak polskich liter w wiadomoś

Postautor: mr.Dark » 20 stycznia 2010, 17:37

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729)

U mnie na 2 komputerach wymagało to ręcznej korekty, po automatycznej aktualizacji Tb2 na Tb3.
mr.Dark
 

Odp: Nieprawidłowe czcionki - brak polskich liter w wiadomoś

Postautor: Narv » 24 stycznia 2010, 11:21

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9.2) Gecko/20100115 Firefox/3.6

U mnie sytuacja występuje zarówno po aktualizacji Thunderbirda z wersji 2 do wersji 3, jak i na świeżo zainstalowanej wersji 3. Co ciekawe sytuacja taka występuję na niektórych kontach email i tylko w przypadku niektórych wiadomości. Zmiana kodowania znaków nie pomaga. Opcja: mailnews.force_charset_override ustawiona jest na false. Na wersji 2 ten problem nie występuje, wygląda to na błąd w Thunderbirdzie, tak jakby nie potrafił poprawnie wykryć kodowania znaków.
Ktoś ma jakieś inne pomysły?
Narv
 

Odp: Nieprawidłowe czcionki - brak polskich liter w wiadomoś

Postautor: deha21 » 06 lutego 2010, 18:44

Przeglądarka: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; pl; rv:1.9.2) Gecko/20100115 Firefox/3.6

Mam to samo :/ Brak polski liter, zamiast nich spacje. Tak samo w Thunderbirdzie 3 jak i Firefoxie w formularzach :/ Dziwne, bo pare dni temu chodziło normalnie a nic nie robi
deha21
 

Odp: Nieprawidłowe czcionki - brak polskich liter w wiadomoś

Postautor: kunajn » 03 marca 2010, 08:15

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9.2) Gecko/20100115 Firefox/3.6

Potwierdzam.

Świeżo zainstalowany TB 3.0.3 nie umie automatycznie wykrywać kodowania w wiadomościach grup dyskusyjnych bez deklaracji kodowania. Niestety część wiadomości jest w UTF, część w ISO. Jak ustawię Widok/Zestaw znaków/Unicode to mi wyświetla krzaki w wiadomościach zakodowanych w ISO i na odwrót. mailnews.force_charset_override jest false.
kunajn
 

Odp: Nieprawidłowe czcionki - brak polskich liter w wiadomoś

Postautor: Piotrek P. » 11 marca 2010, 14:43

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)

ja już to rozwiązałem
wbrew pozorom jest to łatwe do zrobienia :)
choć na początku musiałem sie tym pobawić :P
czyli tak to trzeba zrobić:
NARZĘDZIA -> OPCJE -> WYŚWIETLANIE -> FORMATOWANIE -> i tam gdzie jest czcionka klikamy na ZAAWANSOWANE -> i tam gdzie jest zestaw znaków wybieramy dla poczty przychodzącej i wychodzącej ŚRODKOWOEUROPEJSKI (ISO-8859-2)
i wszystko powinno być już w porządku


nie wiem czy zadziała na inne wersje, ja to robiłem na 3.0.3 czyli tej najnowszej :)
Piotrek P.
 

Odp: Nieprawidłowe czcionki - brak polskich liter w wiadomoś

Postautor: Szubek » 26 marca 2010, 13:52

Przeglądarka: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1) ; Avant Browser; .NET CLR 1.1.4322)

Potwierdzam zadziałało, jak aulga a tyle się z tym męczyłem.
Szubek
 

Odp: Nieprawidłowe czcionki - brak polskich liter w wiadomoś

Postautor: Piorek P. » 17 kwietnia 2010, 07:36

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10

tylko zaś z drugiej strony niektóre wiadomości mogą zawierać inne kodowania
wtedy to co powyżej może nie pomóc
Piorek P.
 

Odp: Nieprawidłowe czcionki - brak polskich liter w wiadomoś

Postautor: anist » 24 kwietnia 2010, 18:39

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 6.0; pl; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)

Piotrek P. pisze:ja już to rozwiązałem
wbrew pozorom jest to łatwe do zrobienia :)
choć na początku musiałem sie tym pobawić :P
czyli tak to trzeba zrobić:
NARZĘDZIA -> OPCJE -> WYŚWIETLANIE -> FORMATOWANIE -> i tam gdzie jest czcionka klikamy na ZAAWANSOWANE -> i tam gdzie jest zestaw znaków wybieramy dla poczty przychodzącej i wychodzącej ŚRODKOWOEUROPEJSKI (ISO-8859-2)
i wszystko powinno być już w porządku


nie wiem czy zadziała na inne wersje, ja to robiłem na 3.0.3 czyli tej najnowszej :)

U mnie to nie działa z tym, że brak polskich znaków występuje tylko w tytule wiadomości, w treści jest ok. Ktoś ma pomysł jak to zmienić?
anist
 
Posty: 8
Z nami od: 03 listopada 2009, 16:58

Odp: Nieprawidłowe czcionki - brak polskich liter w wiadomoś

Postautor: uzytkownik7654 » 16 maja 2010, 14:59

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 6.0; pl; rv:1.9.1.9) Gecko/20100315 Firefox/3.5.9 (.NET CLR 3.5.30729)

Odinstaluj thunderbirda tak jak ja.
Skoro nie potrafili zadbac o to, aby dla nas polakow, maile wyswietlaly sie normalnie, to kij im w oko, po co mam sie meczyc, pytac, pisac i przestawiac ustawienia, na wszelkie mozliwe sposoby - placi mi ktos za to?
Myslalem ze thunderbird faktycznie bedzie lepszy, ale skoro juz na samym poczatku sa problemy (brak polskich liter, brak mozliwosci importu kont mail), to ja robie deinstalacje takiego programu - proste.
Po co mam sie meczyc, skoro mam oryginalnego outlooka 2007 - wiem nie jest to idealny klient, ale bynjmniej nie mam z nim takich problemow, jedyne co mi przeszkadza to wolne otwieranie, dlatego pokusilem sie o thunderbirda, jak widac niepotrzebnie :)
Pozdrawiam

PS.
Jak go dopracuja, to zobaczymy, jak narazie to zlepek kodu, ktory wyglada na prace amatorow, bo jak wytlumaczyc puste okno przy probie importu danych z outlooka?
Normalnie wyskoczylo mi puste okno z przyciskiem dalej....no comment.
uzytkownik7654
 

Odp: Nieprawidłowe czcionki - brak polskich liter w wiadomoś

Postautor: Teodoryk » 18 maja 2010, 11:41

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 6.1; pl; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

Potwierdzam ten sam problem, w tytułach wiadomości brak polskich czcionek w treści już OK,
Teodoryk
 

Odp: Nieprawidłowe czcionki - brak polskich liter w wiadomoś

Postautor: Gość » 08 lipca 2010, 15:20

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 6.1; pl; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6 ( .NET CLR 3.5.30729)

Piotrek P. pisze:ja już to rozwiązałem
wbrew pozorom jest to łatwe do zrobienia :)
choć na początku musiałem sie tym pobawić :P
czyli tak to trzeba zrobić:
NARZĘDZIA -> OPCJE -> WYŚWIETLANIE -> FORMATOWANIE -> i tam gdzie jest czcionka klikamy na ZAAWANSOWANE -> i tam gdzie jest zestaw znaków wybieramy dla poczty przychodzącej i wychodzącej ŚRODKOWOEUROPEJSKI (ISO-8859-2)
i wszystko powinno być już w porządku


nie wiem czy zadziała na inne wersje, ja to robiłem na 3.0.3 czyli tej najnowszej :)


Działa, ale tylko jeśli temat/adresat jest w ISO-8859-2. Przy Windows-1250 będą już "krzaki". Wygląda jakby Thunderbird nie potrafił odczytać prawidłowego kodowania z tematów wiadomości i pola "adresat".
Gość
 

Odp: Nieprawidłowe czcionki - brak polskich liter w wiadomoś

Postautor: Grzegorz » 09 lipca 2010, 08:08

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9.2.7) Gecko/20100701 Firefox/3.6.7

GnuPG. Podpisuję własne wypowiedzi. | TrueCrypt. Ufam kryptografii, nie państwu. | Tor. Dbam o swoją prywatność. | OTR. Moje rozmowy nie są podsłuchiwane.

Załóż konto lub kup domenę WWW z linka polecającego: http://www.hekko.pl/?ref=34295
Grzegorz
Moderator
 
Posty: 7466
Z nami od: 15 kwietnia 2007, 12:33

Odp: Nieprawidłowe czcionki - brak polskich liter w wiadomoś

Postautor: bartkedko » 19 października 2010, 19:05

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 6.1; pl; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10

Witam
Najprostsza metoda
Robimy kopie Thunderbirda za pomocą mozbackup
instalujemy świerzego Thunderbirda
przywracamy kopie, hula sprawdzone
bartkedko
 

Następna

Wróć do Klient poczty Thunderbird

Kto jest online

Zarejestrowani użytkownicy: Baidu [Spider], Bing [Bot], Google [Bot], Yahoo [Bot]

Przejdź do powiązanej strony

Nawigacja:

Stopka: