MozillaPL.org - polskie centrum Mozilli

Główne menu:

Instalator Firefoksa 1.0PR

Forum dla członków zespołu Aviary.pl wydającego Firefoksa i Thunderbirda

Moderator: Pomocy?!

Instalator Firefoksa 1.0PR

Postautor: Cleriic » 09 października 2004, 13:51

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

Udało mi się wreszcie stworzyć instalatora firefoksa. :)

Mam nadzieję, że wyeliminowałem wszystkie przyczyny problemów - przynajmniej te które znalazłem.

Proszę "team" i wszystkich chętnych o przetestowanie: http://pielach.net/aviarypl/
Wybierz Firefoksa i podbij Internet! :)
Cleriic
Moderator
 
Posty: 661
Z nami od: 09 stycznia 2004, 16:04
Lokalizacja: Polska :)

Postautor: Pitreck » 09 października 2004, 14:22

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040802 Firefox/0.9.1+ (Pitreck)

Instalator zdaje sie dzialac poprawnie, dodaje skroty do menu start tam, gdzie powinien, pyta takze przy deinstalacji, czy ma usunac katalog.

Swietna robota, Cleriic!
"Zaczyna się nowy wyścig, ale starzy gracze jeszcze nie umieją zrozumieć, że toczyć się on będzie na zupełnie innym poziomie. Idzie tsunami, a niektórzy dalej zapatrzeni w ziemie stawiają na plaży zamki z piasku i kłócą się, czyj większy..." - Gandalf
Pitreck
Moderator
 
Posty: 1163
Z nami od: 28 listopada 2002, 20:17
Lokalizacja: Wa-wa

Postautor: nikdo » 09 października 2004, 15:42

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl-PL; rv:1.7) Gecko/20040514 Mnenhy/0.6.0.101

u mnie (xp) instalacja (niestandardowa) i deinstalacja bez problemów...
Jest tylko nieprzetłumaczony skrót w menu start: Mozilla Firefox (safe mode).
(można dać 'tryb awaryjny')

n

Połączenia PKP prosto z sidebaru: http://dziedzic.org/pkpanel/
nikdo
 
Posty: 423
Z nami od: 20 lutego 2003, 16:30
Lokalizacja: rybnik

Postautor: Pitreck » 09 października 2004, 15:55

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040802 Firefox/0.9.1+ (Pitreck)

A ja juz zaczalem pliki na sf.net podsylac, ehh, pospiech jednak szkodzi :-?
Musimy sie zdecydowac, jakiego tlumaczenia uzywac dla "Safe mode". Do tej pory w instalatorach uzywalem "Tryb kompatybilności".

[Edit] Przypomnialem sobie, ze zostala nam jeszcze kwestia polskich obrazkow do helpa...
"Zaczyna się nowy wyścig, ale starzy gracze jeszcze nie umieją zrozumieć, że toczyć się on będzie na zupełnie innym poziomie. Idzie tsunami, a niektórzy dalej zapatrzeni w ziemie stawiają na plaży zamki z piasku i kłócą się, czyj większy..." - Gandalf
Pitreck
Moderator
 
Posty: 1163
Z nami od: 28 listopada 2002, 20:17
Lokalizacja: Wa-wa

Postautor: marcoos » 09 października 2004, 16:56

Przeglądarka: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041008 Firefox/0.10

Boże, jaki "tryb kompatybilności"?! Kompatybilności z czym?!

1) "Tryb awaryjny" (tak jest "safe mode" w windows przetłumaczony)
2) "Bez rozszerzeń" (tak to działa)

Lepiej 1.
marcoos
Moderator
 
Posty: 2227
Z nami od: 12 października 2002, 10:25
Lokalizacja: Kraków

Postautor: Pitreck » 09 października 2004, 17:06

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040802 Firefox/0.9.1+ (Pitreck)

Macie racje, dodalem to do slowniczka :)
"Zaczyna się nowy wyścig, ale starzy gracze jeszcze nie umieją zrozumieć, że toczyć się on będzie na zupełnie innym poziomie. Idzie tsunami, a niektórzy dalej zapatrzeni w ziemie stawiają na plaży zamki z piasku i kłócą się, czyj większy..." - Gandalf
Pitreck
Moderator
 
Posty: 1163
Z nami od: 28 listopada 2002, 20:17
Lokalizacja: Wa-wa

Postautor: nikdo » 09 października 2004, 18:07

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl-PL; rv:1.7) Gecko/20040514 Mnenhy/0.6.0.101

Pitreck pisze:[Edit] Przypomnialem sobie, ze zostala nam jeszcze kwestia polskich obrazkow do helpa...


IMHO załatwione ;-):
http://bugs.firefox.pl/show_bug.cgi?id=92

nikdo

Połączenia PKP prosto z sidebaru: http://dziedzic.org/pkpanel/
nikdo
 
Posty: 423
Z nami od: 20 lutego 2003, 16:30
Lokalizacja: rybnik

Postautor: Gandalf » 10 października 2004, 22:43

Przeglądarka: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041001 Firefox/0.10

Panowie, apeluje ponownie, mimo ze Pitreck juz raz zignorowal ;p Jesli _cokolwiek_ tlumaczycie, to NAJPIERW sciagnijcie wersje z CVSa lokalizacji i stosujcie sie do niej. Inaczej skonczymy ze sporym rozrzutem miedzy wydaniem 0.10.1 a pierwszy wydanym z CVSa...
IE jest to aplikacja, która pozwala przeglądać internet z Twojego komputera i na odwrót
Gandalf
 
Posty: 1802
Z nami od: 29 czerwca 2002, 04:37
Lokalizacja: Warszawa

Postautor: Pitreck » 10 października 2004, 22:59

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040802 Firefox/0.9.1+ (Pitreck)

Gandalf, ale w tym konkretnym przypadku (safe mode) chodzilo o plik install.js w browser.xpi :)
I nie tyle zignorowalem, co uznalem, ze nie jest to konieczne, bo nic nie trzeba bylo tlumaczyc, a jedynie pare rzeczu usunac i zmienic w jednym miejscu langplpl.xpi na pl-PL.xpi, przez co poczatkowo instalator sie wywalal.
Pozatym i tak polskich plikow wtedy nie moglem pobrac z CVSa, sciagaly sie wszystkie locale, procz polskiego, a gdy probowalem sciagnac tylko polski, to mowil mi, ze nie ma czegos takiego w CVSie :-?

PS. Jak sie ukazalo, bledne dodawanie skrotow do menu start oraz nie wykrywanie pozostalosci przy instalacji wynikalo z tego, ze nie pozmienialem w paru miejscach en-US na pl-PL w install.js w browser.xpi, co wylapal Cleriic i chwala mu za to!
"Zaczyna się nowy wyścig, ale starzy gracze jeszcze nie umieją zrozumieć, że toczyć się on będzie na zupełnie innym poziomie. Idzie tsunami, a niektórzy dalej zapatrzeni w ziemie stawiają na plaży zamki z piasku i kłócą się, czyj większy..." - Gandalf
Pitreck
Moderator
 
Posty: 1163
Z nami od: 28 listopada 2002, 20:17
Lokalizacja: Wa-wa

Postautor: Gandalf » 11 października 2004, 02:57

Przeglądarka: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041010 Firefox/0.10.1

Jeszcze przypomne dla wszystkich 3 zasady:

1) Wykonujac poprawki do istniejacych plikow, albo podajemy dokladnie co zmieniamy, albo tworzymy patcha i dolaczamy do buga. Dzieki temu kazdy moze latwo obejrzec zmiany

2) Zawsze wykonujemy diffa vs poprzednia wersja

3) Nie zapisujemy Windowsowych znakow konca linii (chyba, ze chcemy miec balagan...)

4) Jak cos, pornujemy z wersja CVS. Dostep do niej wyglada tak:

Kod: Zaznacz cały
export CVSROOT=":pserver:anonymous@cvs-mirror.mozilla.org:/l10n"
cvs login
cvs -d :pserver:anonymous@cvs-mirror.mozilla.org:/l10n co -r AVIARY_1_0_20040515_BRANCH mozilla/toolkit/locales/pl-PL
cvs -d :pserver:anonymous@cvs-mirror.mozilla.org:/l10n co -r AVIARY_1_0_20040515_BRANCH mozilla/browser/locales/pl-PL


W tym momencie jest to troche nieaktualne, ale jutro bede sie tym zajmowal. Bug 210
IE jest to aplikacja, która pozwala przeglądać internet z Twojego komputera i na odwrót
Gandalf
 
Posty: 1802
Z nami od: 29 czerwca 2002, 04:37
Lokalizacja: Warszawa


Wróć do Aviary.pl

Kto jest online

Zarejestrowani użytkownicy: Bing [Bot], Google [Bot], Google Feedfetcher, Majestic-12 [Bot], whatafuuuck

Przejdź do powiązanej strony

Nawigacja:

Stopka: