MozillaPL.org - polskie centrum Mozilli

Główne menu:

Nieprawidłowo wyświetlane textboxy

Tematy specyficzne dla pakietów SeaMonkey oraz Mozilla Suite

Moderator: Pomocy?!

Nieprawidłowo wyświetlane textboxy

Postautor: Descartes » 29 kwietnia 2012, 15:03

Przeglądarka: Mozilla/5.0 (Windows NT 5.2; rv:12.0) Gecko/20120422 Firefox/12.0 SeaMonkey/2.9

Wyjątkowo dziwny problem; Seamonkey 2.9 release PL.
We właściwie każdym textboxie, polu do wprowadzania tekstu, Urlbarze, Searchbarze, ten jest parsowany w taki sposób, że każde słowo zaczyna się od wielkiej litery (np. adres www od "Http", nie "http").
Przykład:
To Jest Tekst Wprowadzony Wyłącznie Małymi Literami. W Przeglądarce Wyświetlany Jest Wersalikami.

Dzieje się to na świeżej instalce SM (w systemie jest jeszcze Chromium, był BlazingFast), na czystym, nowoutworzonym profilu. Postępowanie wg Standardowej Diagnostyki nie rozwiązuje problemu. Usterka tkwi prawie na pewno w przeglądarce -- tekst jest tylko nieprawidłowo wyświetlany (czyżby uszkodzenie jakiegoś wbudowanego arkusza stylu?), wewnętrznie przechowywany jest poprawnie — na ogół przy submitowaniu formularza zostaje zachowana oryginalna treść. W systemie, w tle nie działa jawnie żaden program do manipulowania tekstem.
TIA za pomoc!
Descartes
 

Odp: Nieprawidłowo wyświetlane textboxy

Postautor: Grzegorz » 29 kwietnia 2012, 16:54

Przeglądarka: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:14.0) Gecko/20120424 Firefox/14.0a1

Sprawdź jak zachowuje się wersja przenośna - http://portableapps.com/apps/internet/s ... y_portable
GnuPG. Podpisuję własne wypowiedzi. | TrueCrypt. Ufam kryptografii, nie państwu. | Tor. Dbam o swoją prywatność. | OTR. Moje rozmowy nie są podsłuchiwane.

Załóż konto lub kup domenę WWW z linka polecającego: http://www.hekko.pl/?ref=34295
Grzegorz
Moderator
 
Posty: 7493
Z nami od: 15 kwietnia 2007, 12:33

Odp: Nieprawidłowo wyświetlane textboxy

Postautor: Descartes » 30 kwietnia 2012, 17:13

Przeglądarka: Mozilla/5.0 (Windows NT 5.2; rv:12.0) Gecko/20120422 Firefox/12.0 SeaMonkey/2.9

Dzięki za radę.
Woo hoo. Kompletnie rozsypany interfejs. Wygląda to tak:
Obrazek
(tutaj fullsize: http://i47.tinypic.com/2dsfmug.jpg[gif])
Na innym użytkowniku (koncie systemowym, nie profilu) to samo. Można podejrzewać, że coś jest nie tak z systemem...?
Descartes
 
Posty: 7
Z nami od: 30 kwietnia 2012, 16:39

Odp: Nieprawidłowo wyświetlane textboxy

Postautor: Grzegorz » 01 maja 2012, 10:33

Przeglądarka: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:14.0) Gecko/20120424 Firefox/14.0a1

Nie wygląda to dobrze, a inne programy Mozilli jak się zachowują i/lub wyglądają?

P.S. Możesz to też sprawdzić na wersjach przenośnych z PortableApps.com.
GnuPG. Podpisuję własne wypowiedzi. | TrueCrypt. Ufam kryptografii, nie państwu. | Tor. Dbam o swoją prywatność. | OTR. Moje rozmowy nie są podsłuchiwane.

Załóż konto lub kup domenę WWW z linka polecającego: http://www.hekko.pl/?ref=34295
Grzegorz
Moderator
 
Posty: 7493
Z nami od: 15 kwietnia 2007, 12:33

Odp: Nieprawidłowo wyświetlane textboxy

Postautor: Descartes » 01 maja 2012, 17:16

Przeglądarka: Mozilla/5.0 (Windows NT 5.2; rv:12.0) Gecko/20120422 Firefox/12.0 SeaMonkey/2.9

Thunderbird po aktualizacji do 12.0 zaczął zachowywać się tak samo -- jakby aplikacja rysowała wszystkie możliwe kontrolki -- interfejs w rozsypce:
Obrazek

Prawidłowo działają: Firefox Portable 12.0 Eng, Firefox Portable ESR (10.0.4) Eng, Thunderbird 7.0.1 PL, Thunderbird ESR (10.0.4) PL, ChatZilla 0.9.86-1 Standalone (XUL Runner).

Jeśli byłaby zmiana zw. z biblioteką kontrolek na przestrzeni ostatnich wydań, to może system przestał spełniać jakieś wymagania? Stacja robocza jest na WinNT 5.x (Windows 2000, XP, 2003).

Czyli na teraz bojuję z interfejsem użytkownika:
• Tekst pisany wersalikami w textboxach w SeaMonkey 2.9;
• Rozsypany UI w niektórych wydaniach app Mozilli.

[edit]: +TB ESR 10.0.4, lista problemów.
Descartes
 
Posty: 7
Z nami od: 30 kwietnia 2012, 16:39

SM 2.9.1: problem (Odp: Nieprawidłowo wyświetlane textboxy)

Postautor: Descartes » 02 maja 2012, 19:20

Przeglądarka: Mozilla/5.0 (Windows NT 5.2; rv:12.0) Gecko/20120429 Firefox/12.0 SeaMonkey/2.9.1

Dziś przyszła aktualizacja do SeaMonkey 2.9.1. Problem nadal występuje. :(
Descartes
 
Posty: 7
Z nami od: 30 kwietnia 2012, 16:39

Odp: Nieprawidłowo wyświetlane textboxy

Postautor: Grzegorz » 03 maja 2012, 09:01

Przeglądarka: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:15.0) Gecko/15.0 Firefox/15.0a1

Nie widzę niczego niepokojącego na liście zmian - http://www.seamonkey-project.org/releas ... hanges#new
Wymagania też nie uległy zmianie, w dalszym ciągu wspierane są wersje systemu Windows 2000 w górę - http://www.seamonkey-project.org/doc/sy ... quirements
GnuPG. Podpisuję własne wypowiedzi. | TrueCrypt. Ufam kryptografii, nie państwu. | Tor. Dbam o swoją prywatność. | OTR. Moje rozmowy nie są podsłuchiwane.

Załóż konto lub kup domenę WWW z linka polecającego: http://www.hekko.pl/?ref=34295
Grzegorz
Moderator
 
Posty: 7493
Z nami od: 15 kwietnia 2007, 12:33

Odp: SM 2.9.1: problem (Odp: Nieprawidłowo wyświetlane textb

Postautor: GLI » 03 maja 2012, 11:10

Przeglądarka: Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20120429 SeaMonkey/2.9.1

Descartes pisze:Dziś przyszła aktualizacja do SeaMonkey 2.9.1. Problem nadal występuje. :(


Zmienić motyw graficzny na "Modern" (jeden z dwóch wbudowanych), uruchomić ponownie i sprawdzić jak wygląda po zmianie. Jeśli jest OK, to nie używać starych/niekompatybilnych motywów.
Genuine Lifelike Individual
GLI
 
Posty: 202
Z nami od: 15 maja 2003, 10:38

Odp: SM 2.9.1: problem (Odp: Nieprawidłowo wyświetlane textb

Postautor: Descartes » 03 maja 2012, 18:15

Przeglądarka: Mozilla/5.0 (Windows NT 5.2; rv:12.0) Gecko/20120429 Firefox/12.0 SeaMonkey/2.9.1

GLI pisze:Zmienić motyw graficzny na "Modern" (jeden z dwóch wbudowanych), uruchomić ponownie i sprawdzić jak wygląda po zmianie. Jeśli jest OK, to nie używać starych/niekompatybilnych motywów.

Niestety to nie to. Zjawisko występuje niezależnie od motywu (wypróbowałem: SeaMonkey Modern, SeaMonkey Default, Classic Firefox Theme for SeaMonkey). Ale to może być słuszny trop; nie wiesz, czy jest jakiś .css/plik chrome, który byłby nadrzędny dla motywów?
Descartes
 
Posty: 7
Z nami od: 30 kwietnia 2012, 16:39

Odp: SM 2.9.1: problem (Odp: Nieprawidłowo wyświetlane textb

Postautor: GLI » 03 maja 2012, 21:52

Przeglądarka: Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20120429 SeaMonkey/2.9.1

Descartes pisze:
GLI pisze:Zmienić motyw graficzny na "Modern" (jeden z dwóch wbudowanych), uruchomić ponownie i sprawdzić jak wygląda po zmianie. Jeśli jest OK, to nie używać starych/niekompatybilnych motywów.

Niestety to nie to. Zjawisko występuje niezależnie od motywu (wypróbowałem: SeaMonkey Modern, SeaMonkey Default, Classic Firefox Theme for SeaMonkey). Ale to może być słuszny trop; nie wiesz, czy jest jakiś .css/plik chrome, który byłby nadrzędny dla motywów?


Domyślnie motywy są w "c:\Program Files\SeaMonkey\extensions\".

Proponuję następujące kroki naprawcze:
- odinstalować SeaMoneky (za pomocą funkcji Windowsa), profile nie będą ruszone,
- usunąć katalog "c:\Program Files\SeaMonkey\" wraz z ewentualną zawartością,
- pobrać najnowszą wersję SM (2.9.1),
- sprawdzić sumy kontrolne (mój gotowy plik: [RS]), za pomocą np. HashTab (ja używam Total Commandera),
- zainstalować ponownie SM (upewniwszy się wprzód, iż prawa administratora się posiada).

Zakładam, że SM i TB nie dzielą "przypadkiem" wspólnego profilu użytkownika... ;)

"Windows NT 5.2"?! Czy to nie jest przypadkiem system 64-bitowy (XP 64-bit / Server 2003 / Home Server)? Uuu... może być wąsko... :?
Genuine Lifelike Individual
GLI
 
Posty: 202
Z nami od: 15 maja 2003, 10:38

Odp: Nieprawidłowo wyświetlane textboxy

Postautor: Descartes » 11 maja 2012, 03:51

Przeglądarka: Mozilla/5.0 (Windows NT 5.2) AppleWebKit/535.19 (KHTML, like Gecko) Iron/18.0.1050.0 Chrome/18.0.1050.0 Safari/535.19

Najpierw dzięki za wskazówki i sorry za długą zwłokę. Majówki i, niestety, frustracja z porażki. Po czystej reinstalce, UI wygląda teraz jak na tym screenshocie: Obrazek
W \extensions\ nie widzę nic niezwykłego.
Czyli punkt wyjścia. Coś zarazem się zmieniło, bo po skasowaniu %ProgramFiles%\SeaMonkey i zainstalowaniu na nowo interfejs się rozsypał...
SM i TB nie dzielą tego samego profilu. Testuję na czystym, założonym przez menedżer profili.
TB ESR 10.0.4 działa prawidłowo.
WinNT 5.2 -- nie tylko 64-bitowy, także Win2003 x86 (32-bit). FF/SM wspiera ten OS.
Descartes
 
Posty: 7
Z nami od: 30 kwietnia 2012, 16:39

Odp: Nieprawidłowo wyświetlane textboxy

Postautor: GLI » 11 maja 2012, 19:19

Przeglądarka: Mozilla/5.0 (Windows NT 6.1; rv:12.0) Gecko/20120429 SeaMonkey/2.9.1

Descartes pisze:Najpierw dzięki za wskazówki i sorry za długą zwłokę. Majówki i, niestety, frustracja z porażki. Po czystej reinstalce, UI wygląda teraz jak na tym screenshocie:
[ciach]
W \extensions\ nie widzę nic niezwykłego.
Czyli punkt wyjścia. Coś zarazem się zmieniło, bo po skasowaniu %ProgramFiles%\SeaMonkey i zainstalowaniu na nowo interfejs się rozsypał...
SM i TB nie dzielą tego samego profilu. Testuję na czystym, założonym przez menedżer profili.
TB ESR 10.0.4 działa prawidłowo.
WinNT 5.2 -- nie tylko 64-bitowy, także Win2003 x86 (32-bit). FF/SM wspiera ten OS.


Jeśli W2k3 jest w pełni załatany i nie ma "szkodników", to obawiam się, że więcej nie wymyślimy. Na forum Mozilli o błędach SeaMonkey być może znajdzie się ktoś, kto używa 2003 Server jako stację roboczą i ma doświadczenie z podobnym problemem. No i deweloperzy tam zaglądają... ;)

BTW Jaka jest ustawiona rozdzielczość ekranu i czy zmienione zostało DPI z domyślnego?

EDIT: Lub lepiej na forum pomocy dla SeaMonkey. Jaka wersja Java? Podobno 7 Update 4 sprawia problemy. Ja używam 6 Update 32, bo niektóre programy nie obsługują nowszej wersji...
Genuine Lifelike Individual
GLI
 
Posty: 202
Z nami od: 15 maja 2003, 10:38

Odp: Nieprawidłowo wyświetlane textboxy

Postautor: Descartes » 12 maja 2012, 02:09

Przeglądarka: Mozilla/5.0 (Windows NT 5.2) AppleWebKit/535.19 (KHTML, like Gecko) Iron/18.0.1050.0 Chrome/18.0.1050.0 Safari/535.19

Wydaje się, że trop słuszny. W2k3 wygląda na to, że nie jest w pełni zakutalizowany (adminuję tą stacją z doskoku). Podejrzenie padło już na system (choć objaw zaiste nietypowy), niemniej kilka AV nie stwierdziło żadnego malware'u (firewall, patche antywormowe, regularny user nie jest adminem). Mimo to skłonny jestem przyznać, że winny może być OS.
Java jest 6u31.
Rozdzielczość: 1280x800x24bpp, DPI: 96 (domyślne). Grafika (i sterownik do niej) antyczne.
Gdy mi się uda dopilnować aktualizacji i problem nie ustąpi, to napiszę we wskazane miejsce. Dzięki za pomoc!
Descartes
 
Posty: 7
Z nami od: 30 kwietnia 2012, 16:39


Wróć do Pakiet SeaMonkey i Mozilla Suite

Kto jest online

Zarejestrowani użytkownicy: dexter

Przejdź do powiązanej strony

Nawigacja:

Stopka: