MozillaPL.org - polskie centrum Mozilli

Główne menu:

Problem z XBL

Projektowanie aplikacji i rozszerzeń opartych na technologiach Mozilla Foundation: XUL, JavaScript, XPCOM, XBL i innych

Moderator: Pomocy?!

Problem z XBL

Postautor: mz » 23 czerwca 2003, 10:09

Przeglądarka: -

Podejrzewam, że mam bardzo trywialny problem :D .
Nie chce mi się "podłączyć" xbl do boxa w XUL-u
plik CSS
Kod: Zaznacz cały
box.labeltextbox {
   -moz-binding: url("chrome://contract/content/contract.xml#labeltextbox");
}

plik XBL
Kod: Zaznacz cały
<?xml version="1.0"?>
<bindings id="contractBindings"
          xbl="http://www.mozilla.org/xbl"
          xmnls:xbl="http://www.mozilla.org/xbl"
          xmlns:xul="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul">
<xbl:binding id="labeltextbox">
<xbl:content>
  <xul:label/>
  <xul:textbox/>
</xbl:content> 
</xbl:binding>
</bindings>

Co robię źle? Sprawdzałem w DOM insektorze CSS jest dopięty do mojego boxa.
Plik chrome://contract/content/contract.xml#labeltextbox mogę otworzyć w mozilli.

Przy okazji jeszcze jedno pytanie gdy zmieniam pliki w katalogu chrome muszę wyłączyć i włączyć mozille żeby zauważyła zmianę. Czy jest jakiś sposób na odświeżenie bez wyłączania mozilli?
mz
 
Posty: 30
Z nami od: 11 lutego 2003, 20:54
Lokalizacja: Stegny

Re: Problem z XBL

Postautor: prefiks » 23 czerwca 2003, 19:04

Przeglądarka: -

Spróbuj tego:
Kod: Zaznacz cały
<xbl:bindings id="contractBindings"
[...]
</xbl:bindings>
prefiks
 
Posty: 179
Z nami od: 30 grudnia 2002, 01:45


Wróć do Programowanie z użyciem technologii Mozilli

Kto jest online

Zarejestrowani użytkownicy: Bing [Bot], Google [Bot]

Przejdź do powiązanej strony

Nawigacja:

Stopka: