MozillaPL.org - polskie centrum Mozilli

Główne menu:

Flaga media.autoplay.enabled

Tematy specyficzne dla przeglądarki Mozilla Firefox

Moderator: Pomocy?!

Flaga media.autoplay.enabled

Postautor: Pawel7910 » 02 lipca 2018, 15:02

Przeglądarka: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0

Witam.

Otóż podczas korzystania z stabilnego wydania Firefox 61 (x64) zauważyłem że mimo zmiany ustawienia flagi w about:config - media.autoplay.enabled z true na false na stronie http://www.onet.pl mimo wszystko uruchamiają się automatycznie.
W poprzedniej wersji stabilnej Fx 60.0 oraz w wersji Fx 62.0 beta 4 wszystko działa jak należy. Więc podejrzewam, że jest to jakiś błąd.

Aktualizacja

Wydanie wersji poprawkowej Firefox 61.0.1 w dalszym ciągu nie rozwiązuje tego problemu.

Aktualizacja 08.08.2018

Wydanie 61.0.2 dalej nie zawiera poprawki tego buga.

Czy u Was też taki problem występuje ?
Ostatnio zmieniony 08 sierpnia 2018, 20:39 przez Pawel7910, łącznie zmieniany 2 razy
Pawel7910
 
Posty: 3
Z nami od: 02 lipca 2018, 14:52

Odp: Flaga media.autoplay.enabled

Postautor: krystian3w » 02 lipca 2018, 20:08

Przeglądarka: Mozilla/5.0 (Windows NT 10.0; rv:61.0) Gecko/20100101 Firefox/61.0

krystian3w
 
Posty: 361
Z nami od: 01 grudnia 2017, 15:27

Odp: Flaga media.autoplay.enabled

Postautor: Pawel7910 » 17 lipca 2018, 19:03

Przeglądarka: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

krystian3w pisze:Też mi nie działa.

"Jak zablokować autoodtwarzanie filmików?".


Jeśli chodzi o rozszerzenie Flash Stopper nie jest ono obecnie rozwijane przez autora dla przeglądarki Firefox od wersji 57.
Pawel7910
 
Posty: 3
Z nami od: 02 lipca 2018, 14:52

Odp: Flaga media.autoplay.enabled

Postautor: beata072 » 18 lipca 2018, 00:27

Przeglądarka: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

U mnie też nie działa
beata072
 
Posty: 1103
Z nami od: 27 lutego 2010, 04:18

Odp: Flaga media.autoplay.enabled

Postautor: krystian3w » 18 lipca 2018, 13:34

Przeglądarka: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.87 Safari/537.36 OPR/54.0.2952.54

krystian3w
 
Posty: 361
Z nami od: 01 grudnia 2017, 15:27

Odp: Flaga media.autoplay.enabled

Postautor: beata072 » 18 lipca 2018, 14:12

Przeglądarka: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0 Cyberfox/52.5.2

E no, nie będę instalować dodatku, kiedy ta opcja miała być wbudowana. Zaczekam, może to naprawią
beata072
 
Posty: 1103
Z nami od: 27 lutego 2010, 04:18

Odp: Flaga media.autoplay.enabled

Postautor: krystian3w » 18 lipca 2018, 14:55

Przeglądarka: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.87 Safari/537.36 OPR/54.0.2952.54

O ile Onet jakoś skryptem nie obchodzi blokady.
krystian3w
 
Posty: 361
Z nami od: 01 grudnia 2017, 15:27

Odp: Flaga media.autoplay.enabled

Postautor: Pawel7910 » 19 lipca 2018, 09:37

Przeglądarka: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.99 Safari/537.36

krystian3w pisze:O ile Onet jakoś skryptem nie obchodzi blokady.


Raczej w przypadku onet.pl jak i na komputerswiat.pl, newsweek.pl nie wchodzi w grę żaden skrypt omijający blokadę.
W Firefox 62 beta media.autoplay.enabled z ustawieniem na false działa bez problemu i blokuje auto uruchamianie odtwarzania.

Ogólnie dosyć często porównuje działanie wersji stabilnych z wersjami beta i często jest tak że wersje beta działają po prostu lepiej niż potem gdy osiągają status release. Nie jest to może regułą, ale często właśnie odnoszę takie wrażenie.
Pawel7910
 
Posty: 3
Z nami od: 02 lipca 2018, 14:52

Odp: Flaga media.autoplay.enabled

Postautor: dexter » 21 lipca 2018, 13:05

Przeglądarka: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

Wideo odtwarzane bez dźwięku póki co ma prawo się samo uruchomić (wg specyfikacji HTML5). To ma być wkrótce zmienione.

Niedługo też będzie można ustawiać wyjątki dla wybranych subdomen.

Spróbujcie media.autoplay.enabled.user-gestures-needed = false, przynajmniej mi to zadziałało na wp.pl (w Nightly 63).
dexter
Moderator
 
Posty: 7407
Z nami od: 02 października 2004, 21:30

Odp: Flaga media.autoplay.enabled

Postautor: krystian3w » 21 lipca 2018, 14:14

Przeglądarka: Mozilla/5.0 (Windows NT 10.0; rv:61.0) Gecko/20100101 Firefox/61.0

Na stabilnej wersji z onetem nie działa, mogę spróbować zainstalować przenośne nightly:

FirefoxPortableNightly_63.0_Alpha_1_Pre_Polish_online.paf.exe

W Nightly 63 niby powstrzymuje wideo "Serwis informacyjny ONET24" przed załadowaniem - buforuje bez końca.
Ostatnio zmieniony 21 lipca 2018, 14:23 przez krystian3w, łącznie zmieniany 1 raz
krystian3w
 
Posty: 361
Z nami od: 01 grudnia 2017, 15:27

Odp: Flaga media.autoplay.enabled

Postautor: dexter » 21 lipca 2018, 14:17

Przeglądarka: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

Podaj linka, bo na onecie nie mogę natrafić na żaden film.
dexter
Moderator
 
Posty: 7407
Z nami od: 02 października 2004, 21:30

Odp: Flaga media.autoplay.enabled

Postautor: krystian3w » 21 lipca 2018, 14:25

Przeglądarka: Mozilla/5.0 (Windows NT 10.0; rv:61.0) Gecko/20100101 Firefox/61.0

Ja testuje na wideo pod nagłówkiem "Serwis informacyjny ONET24"

Kod: Zaznacz cały
https://onet100.vod.pl/i/news/onet24-samochod-uderzyl-w-nastolatki/kzsp6d
krystian3w
 
Posty: 361
Z nami od: 01 grudnia 2017, 15:27

Odp: Flaga media.autoplay.enabled

Postautor: dexter » 21 lipca 2018, 14:31

Przeglądarka: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

U mnie tam jest tylko czarne pole na film i pod spodem kręci się kółeczko, dopóki nie wybiorę Odtwórz z menu kontekstowego.
dexter
Moderator
 
Posty: 7407
Z nami od: 02 października 2004, 21:30

Odp: Flaga media.autoplay.enabled

Postautor: krystian3w » 21 lipca 2018, 14:33

Przeglądarka: Mozilla/5.0 (Windows NT 10.0; rv:61.0) Gecko/20100101 Firefox/61.0

A da się by Firefox 63 czekał dłużej niż 5 sekund po takim okienku:

https://i.imgur.com/mK4SeOk.png

Co do menu to najgorzej jak je zablokują lub podmienią na niefunkcjonalne.

Jak wycinałem zrzut, to po chwili odtworzyło się wideo, klucz był na domyślnej wartości = True.
krystian3w
 
Posty: 361
Z nami od: 01 grudnia 2017, 15:27

Odp: Flaga media.autoplay.enabled

Postautor: dexter » 21 lipca 2018, 14:38

Przeglądarka: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

To jest jeszcze "under heavy development" ;), pewnie będzie jeszcze poprawiane.
dexter
Moderator
 
Posty: 7407
Z nami od: 02 października 2004, 21:30

Odp: Flaga media.autoplay.enabled

Postautor: Garu » 21 lipca 2018, 18:09

Przeglądarka: Mozilla/5.0 (Windows NT 5.1; rv:52.9) Gecko/20100101 Goanna/4.1 Firefox/52.9 PaleMoon/28.0.0b2

Obok media.autoplay.enabled ustawionego na false, to trzeba jeszcze to ustawić na true:
media.block-autoplay-until-in-foreground
Dużo skryptów z onetu blokuję i wystarczają moje ustawienia.
http://prntscr.com/k9a9b1
Nie liczyłbym na to, że Firefox naprawi system.
Garu
 
Posty: 1107
Z nami od: 31 stycznia 2014, 18:55

Odp: Flaga media.autoplay.enabled

Postautor: krystian3w » 21 lipca 2018, 20:11

Przeglądarka: Mozilla/5.0 (Windows NT 10.0; rv:61.0) Gecko/20100101 Firefox/61.0

ale ten drugi ma domyślnie true (przynajmniej w Firefox 60 - 61):

https://i.imgur.com/Q3YNeaB.png

I nie działa taka konfiguracja w FX61 / 61.0.1 - trzeba używać wersji starszych (60 - 52) lub niestabilnych bety 62 / Nightly 63 (media.autoplay.enabled.user-gestures-needed = false).

Nie wiem co napsuli, że nie naprawili tego w 61.0.1.
krystian3w
 
Posty: 361
Z nami od: 01 grudnia 2017, 15:27


Wróć do Przeglądarka Firefox

Kto jest online

Zarejestrowani użytkownicy: Bing [Bot], Google [Bot], thehay95

Przejdź do powiązanej strony

Nawigacja:

Stopka: