MozillaPL.org - polskie centrum Mozilli

Główne menu:

User Agent, a widzenie youtube

Tematy specyficzne dla przeglądarki Mozilla Firefox

Moderator: Pomocy?!

User Agent, a widzenie youtube

Postautor: covo » 31 grudnia 2018, 10:31

Przeglądarka: Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.9.0

W uzywanym, z natywnym User Agent, ff 52.9 strone youtube widze normalnie, tzn tak -> https://i.imgur.com/IhV19as.png
Takze gdy zmieniam User Agent na ponizsze (przykladowe) - widze yt bez problemu:

Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0
Mozilla/5.0 (X11; FreeBSD amd64; rv:54.0) Gecko/20100101 Firefox/54.0
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:63.0) Gecko/20100101 Firefox/63.0
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

Ale przy ponizszych User Agent strone yt "widze" juz tylko tak --> https://i.imgur.com/T0qiVrc.png

Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.102 Safari/537.36
Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.102 Safari/537.36
Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/69.0.3497.100 Safari/537.36 OPR/56.0.3051.104

Kto potrafi ten fenomen wyjasnic? Jakis blad "konstrukcyjny" na yt?
covo
 
Posty: 1352
Z nami od: 21 maja 2003, 01:02

Odp: User Agent, a widzenie youtube

Postautor: dexter » 31 grudnia 2018, 12:00

Przeglądarka: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Błąd byłby przypadkowy, a to zrobili specjalnie, by wolniej wyświetlać yt w innych niż chrome przeglądarkach. Wersja yt dla chrome jest budowana za pomocą biblioteki Polymer opierającej się na przestarzałym API Shadow DOM v0, z którego korzysta jedynie Chrome.
dexter
Moderator
 
Posty: 7586
Z nami od: 02 października 2004, 21:30

Odp: User Agent, a widzenie youtube

Postautor: covo » 31 grudnia 2018, 16:05

Przeglądarka: Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.9.0

czyli yt odbiera mojego ff jako chrome, ale nic wiecej nie pokaze, bo ff nie ma tych starych skladnikow API? tak jest?
covo
 
Posty: 1352
Z nami od: 21 maja 2003, 01:02

Odp: User Agent, a widzenie youtube

Postautor: dexter » 31 grudnia 2018, 16:18

Przeglądarka: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

No, jakoś tak.
dexter
Moderator
 
Posty: 7586
Z nami od: 02 października 2004, 21:30

Odp: User Agent, a widzenie youtube

Postautor: jakniejaktak » 31 grudnia 2018, 19:18

Przeglądarka: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

Włącz sobie stary wygląd YT to będzie działać. Jak to zrobić jest opisane tu: viewtopic.php?f=15&t=49860
jakniejaktak
 
Posty: 61
Z nami od: 02 czerwca 2008, 20:15

Odp: User Agent, a widzenie youtube

Postautor: krystian3w » 31 grudnia 2018, 21:22

Przeglądarka: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

krystian3w
 
Posty: 639
Z nami od: 01 grudnia 2017, 15:27

Odp: User Agent, a widzenie youtube

Postautor: Garu » 01 stycznia 2019, 01:44

Przeglądarka: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.116 Safari/537.36 Edge/15.15063

Ja na basilisku 55 zrobiłem sobie useragenta na win 10 i edge, na YT też ten sam useragent i na ipla, żeby filmy szły na XP
http://prntscr.com/m1rccb
Nie liczyłbym na to, że Firefox naprawi system.
Garu
 
Posty: 1149
Z nami od: 31 stycznia 2014, 18:55

Odp: User Agent, a widzenie youtube

Postautor: krystian3w » 01 stycznia 2019, 02:49

Przeglądarka: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

A ten problem z kodekiem dźwięku DRM sam user-agent rozwiązuje?

https://www.ipla.tv/wideo/serial/Swiat-wedlug-Kiepskich/759/Sezon-1/760/Swiat-wedlug-Kiepskich-Odcinek-145/4063

Ostatnio nawet wyskoczył komunikat brzmiący jak na górze, że z winy DRM dźwięk się może nie odtworzyć.
krystian3w
 
Posty: 639
Z nami od: 01 grudnia 2017, 15:27

Odp: User Agent, a widzenie youtube

Postautor: Garu » 01 stycznia 2019, 11:37

Przeglądarka: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.116 Safari/537.36 Edge/15.15063

U mnie DRM wyłączone, a film u mnie idzie z wdziękiem i dźwiękiem ;)
http://prntscr.com/m1tw7b
Nie widziałem żadnych komunikatów...
Nie liczyłbym na to, że Firefox naprawi system.
Garu
 
Posty: 1149
Z nami od: 31 stycznia 2014, 18:55

Odp: User Agent, a widzenie youtube

Postautor: covo » 02 stycznia 2019, 00:13

Przeglądarka: Mozilla/5.0 (MSIE 9.0; Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.79 Safari/537.36 Edge/14.14931

dexter pisze:No, jakoś tak.


ok, czyli na ff z user agentem symulujacym konkretna wersje chrome nie zobacze dobrze yt, bo ff i tak nie zawiera tego i owego z chrome, ale tez - jak napisalem wyzej - nie widze dobrze yt gdy user agentem symuluje np. opere 56 robiona na chrome (chromium?):

Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/69.0.3497.100 Safari/537.36 OPR/56.0.3051.104

Wiec pytanie:
dlaczego widze dobrze yt z user agentem majacym symulowac konkretna wersje np. Edge?:

Mozilla/5.0 (MSIE 9.0; Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.79 Safari/537.36 Edge/14.14931

- Edge zdaje sie bazuje na chromium (?)... Czy to za malo, zeby "bazowal" na chrome i dlatego symulujac w ff -> edge widze jednak yt?
Po prostu user agent MUSI wskazywac dokladnie na chrome, zeby byly klopoty z yt w ff?
covo
 
Posty: 1352
Z nami od: 21 maja 2003, 01:02

Odp: User Agent, a widzenie youtube

Postautor: krystian3w » 02 stycznia 2019, 00:37

Przeglądarka: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

Ale mi chodzi o Firefox / palemoon / basilisk a nie Edge 15 z Windows 10 i koniecznie stare odcinki np. 1 sezon ŚwK.
krystian3w
 
Posty: 639
Z nami od: 01 grudnia 2017, 15:27

Odp: User Agent, a widzenie youtube

Postautor: covo » 02 stycznia 2019, 00:41

Przeglądarka: Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.9.0

jakniejaktak pisze:Włącz sobie stary wygląd YT to będzie działać. Jak to zrobić jest opisane tu: viewtopic.php?f=15&t=49860


nie mam klopotow z ogladaniem yt na xp i z natywnym (widac jakim) user agentem w ff.
ale czasami wypada mi (b. sporadycznie, dla ogladania pewnych www) zmienic UA i zupelnie przypadkowo, przy okazji, zauwazylem, ze UA wskazujacy na uzywanie konkretnej wersji chrome daje kaleki wyglad yt w ff. Stad zalozony temat.
Inny UA, poza wskazujacym na chrome, daje u mnie zawsze prawidlowy oglad yt na xp.
covo
 
Posty: 1352
Z nami od: 21 maja 2003, 01:02

Odp: User Agent, a widzenie youtube

Postautor: covo » 02 stycznia 2019, 01:02

Przeglądarka: Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.9.0

krystian3w pisze:A ten problem z kodekiem dźwięku DRM sam user-agent rozwiązuje?

https://www.ipla.tv/wideo/serial/Swiat-wedlug-Kiepskich/759/Sezon-1/760/Swiat-wedlug-Kiepskich-Odcinek-145/4063

Ostatnio nawet wyskoczył komunikat brzmiący jak na górze, że z winy DRM dźwięk się może nie odtworzyć.


ja na xp i z moim UA widze tylko czarny ekran, dopiero po zmianie UA na (np.) win7 / ff 57 - przynajmniej moge wykonac download video (z audio); co do ogladania tylko online: jakos nie chce mi sie zabuforowac, po znaczniku na ekranie widac, ze laduje sie i laduje... (a wszelkie blockery powylaczane).
covo
 
Posty: 1352
Z nami od: 21 maja 2003, 01:02

Odp: User Agent, a widzenie youtube

Postautor: Garu » 02 stycznia 2019, 04:41

Przeglądarka: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.116 Safari/537.36 Edge/15.15063

A swoją drogą - XP - uruchamiają się filmiki na tej stronie? https://www.tvn24.pl/najnowsze,49
Nie liczyłbym na to, że Firefox naprawi system.
Garu
 
Posty: 1149
Z nami od: 31 stycznia 2014, 18:55

Odp: User Agent, a widzenie youtube

Postautor: covo » 02 stycznia 2019, 14:14

Przeglądarka: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.102 Safari/537.36

Garu pisze:A swoją drogą - XP - uruchamiają się filmiki na tej stronie? https://www.tvn24.pl/najnowsze,49

zartujesz :)
(symulowanie jakiegokolwiek UA nie pomaga, blockery wszelkie wylaczone)

swoja droga - moze ktos jest biegly i np. przez F12 potrafi wyczaic przyczyne
covo
 
Posty: 1352
Z nami od: 21 maja 2003, 01:02

Odp: User Agent, a widzenie youtube

Postautor: krystian3w » 03 stycznia 2019, 11:18

Przeglądarka: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.102 Safari/537.36 OPR/57.0.3098.106

Może stary problem z MP4? https://msfn.org/board/topic/175591-enable-mp4-h264-aac-html5-video-in-firefox-on-windows-xp-without-flash/.

Ale to niby macie przecież wykonane przed blokadą instalacji wtyczki automatycznie:
IMPORTANT: The Primetime CDM plugin can no longer be downloaded from Adobe servers (...)


Kod: Zaznacz cały
https://r.dcs.redcdn.pl/https/o2/tvn/web-content/m/p1/v/d54e99a6c03704e95e6965532dec148b/69161932-e438-4a76-b508-57852ebc4725-720p.mp4
https://r.dcs.redcdn.pl/https/o2/tvn/web-content/m/p1/v/d54e99a6c03704e95e6965532dec148b/69161932-e438-4a76-b508-57852ebc4725-480p.mp4
https://r.dcs.redcdn.pl/https/o2/tvn/web-content/m/p1/v/d54e99a6c03704e95e6965532dec148b/69161932-e438-4a76-b508-57852ebc4725-360p.mp4
https://r.dcs.redcdn.pl/https/o2/tvn/web-content/m/p1/v/d54e99a6c03704e95e6965532dec148b/2d5f4b3d-cf26-4ade-80a1-0d2df620344f-240p.mp4

nie wiem jak szybko link padnie. Niby ten najgorszy już ma jakieś inne wylosowane atrybuty.
krystian3w
 
Posty: 639
Z nami od: 01 grudnia 2017, 15:27

Odp: User Agent, a widzenie youtube

Postautor: Garu » 03 stycznia 2019, 13:00

Przeglądarka: Mozilla/5.0 (Windows NT 5.1; rv:60.9) Gecko/20100101 Goanna/4.1 Firefox/60.9 Mypal/28.2.2

A uruchamiają mi się filmiki na wiadomości tvn24. Nawet na palemoonie 28.2.2. Przyczyna była w blokowaniu autoplay
media.autoplay.allowscripted - dałem na true i media.autoplay.enabled - tak samo na true i wszystkie filmy nagle ruszyły, a mam włączony ublock origin, disconnect i tam parę roszerzen do pilnowania wyskakujących okien, czy przed minerami.
Nie liczyłbym na to, że Firefox naprawi system.
Garu
 
Posty: 1149
Z nami od: 31 stycznia 2014, 18:55

Odp: User Agent, a widzenie youtube

Postautor: covo » 03 stycznia 2019, 13:39

Przeglądarka: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.102 Safari/537.36

krystian3w pisze:Może stary problem z MP4?

to nie to
covo
 
Posty: 1352
Z nami od: 21 maja 2003, 01:02

Odp: User Agent, a widzenie youtube

Postautor: covo » 03 stycznia 2019, 13:42

Przeglądarka: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.102 Safari/537.36

Garu pisze:media.autoplay.enabled - tak samo na true

i to jest to. thx.
(z tym, ze blockery - juz nie kojarze, czy wszystkie - musze miec WYlaczone, Privacy Badger z pewnoscia)
covo
 
Posty: 1352
Z nami od: 21 maja 2003, 01:02

Odp: User Agent, a widzenie youtube

Postautor: krystian3w » 03 stycznia 2019, 14:20

Przeglądarka: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.102 Safari/537.36 OPR/57.0.3098.106

Może przez to że filtry przeciwko wykrywaniu adblocka zostały przeniesione?

viewtopic.php?f=24&p=243881#p243881

Niby w uBO ma się to samo zaznaczyć (albo od nowej instalacji dodatku), ale nie wiem jak tam to wam ogarnia wydanie 1.13.8 lub firefox-legacy-1.16.4.6.
krystian3w
 
Posty: 639
Z nami od: 01 grudnia 2017, 15:27

Następna

Wróć do Przeglądarka Firefox

Kto jest online

Zarejestrowani użytkownicy: Bing [Bot], Google [Bot]

Przejdź do powiązanej strony

Nawigacja:

Stopka: