MozillaPL.org - polskie centrum Mozilli

Główne menu:

Róznice w wielkości ramek w Mozilla i IE

Dyskusje na temat standardów WWW i zgłoszenia stron niedziałających poprawnie w przeglądarkach z rodziny Mozilli (w tym Mozilla Firefox)

Moderator: Pomocy?!

Róznice w wielkości ramek w Mozilla i IE

Postautor: adher » 17 listopada 2008, 10:47

Przeglądarka: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322)

Witam, stworzylem swoja pierwsza strone www w html korzystajac z gotowych szablonow. Niestety strona wyswietla sie poprawnie jedynie w IE. W Mozilla widoczne sa „robocze” ramki w których zagniezdzona jest grafika np. /start_de.html.

Jesli szanowni koledzy webmasterzy macie chwile to proszę o wasze wskazowki jak to poprawic. Zrobiłem oczywiście walidacje, przejrzałem forum, jednak jestem naprawde zielony i mimo dobrych checi nie potrafie się z tym uporac.

Adres strony to www.dpsynergia.pl

Z gory dzieki za poswiecony czas! Moze ja bede mogl pomoc Wam kiedys w czyms innym :D
adher
 
Posty: 3
Z nami od: 17 listopada 2008, 09:34

Postautor: Tomek » 17 listopada 2008, 11:34

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

1. skoro zrobiłeś walidację - to popraw błędy: http://validator.w3.org/check?verbose=1 ... rgia.pl%2F
2. http://osiolki.net/tabelki/ - dlaczego układ na tabelkach jest głupi
3. akurat to Fx wyświetla prawidłowo a IE z błędem - na 99% wina tkwi w tzw. boxmodel: http://kurs.browsehappy.pl/CSS/BoxModel - tu masz o tym problemie więcej http://www.google.pl/search?hl=pl&q=box ... Szukaj&lr=
4. ten 1% niepewności zostawiam na tabelki...
"Mym sojusznikiem jest Moc, i potężnym sojusznikiem ona jest." -- Mistrz Yoda
Tomek
Moderator
 
Posty: 9049
Z nami od: 19 sierpnia 2004, 06:52

Postautor: adher » 17 listopada 2008, 12:19

Przeglądarka: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322)

tomasiek pisze:1. skoro zrobiłeś walidację - to popraw błędy:


Robilem w celach diagnostycznych. Jak tylko czas pozwoli wprowadze zmiany na strone!

Tomasiek -> ogolnie wielkie dzieki, mam lekture na kilka wieczorow ;) Jak widac najpierw musze poćwiczyć jezyk html, pozniej przyjdzie czas na eksperymenty z wyswietlaniem mojej strony. Mam juz jednak punkt zaczepienia – w zyciu nie przypuszczalbym za blad lezy po stronie IE a nie Mozilli?! W każdym razie sprobuje wyrzucic te cholerne pudelka…

Każdy z was kiedys zaczynal! No nie? ;) Z gory dzieki za cierpliwosc i wyrozumialosc!
adher
 
Posty: 3
Z nami od: 17 listopada 2008, 09:34

Postautor: Tomek » 17 listopada 2008, 12:28

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

hm.. .szczerze mówiąc pozytywnie mnie zaskoczyłeś swoją wypowiedzią - zazwyczaj troszkę inaczej ludzie reagują na takie rady...
ps - IE w wersji 6.0 czy nawet 7.0 to daleko ma jeszcze do przeglądarki - IE 8 beta już o wiele lepiej się tu prezentuje.
Polecam ogólnie kurs na browserhappy - dobry, konkretny. No i google - jeśli coś ci się "poprawnie" wyświetla w IE a źle w Geckowatych - to na 99,9% wina tkwi w IE i w kodzie :)
"Mym sojusznikiem jest Moc, i potężnym sojusznikiem ona jest." -- Mistrz Yoda
Tomek
Moderator
 
Posty: 9049
Z nami od: 19 sierpnia 2004, 06:52

Postautor: adher » 17 listopada 2008, 16:23

Przeglądarka: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322)

Problem zdiagnozowany – podczas edycji stron (edytor u mojego dostawcy hostingu) dopisywalo mi się przy zapisywaniu zmian na stronie w pierwszej linijce kodu cos takiego <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

Bledne wyświetlanie strony powodowane było oczywiscie zbednym wykrzykniekiem „!”
adher
 
Posty: 3
Z nami od: 17 listopada 2008, 09:34

Postautor: helios » 26 listopada 2008, 22:42

Przeglądarka: Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.9.0.4) Gecko/2008111318 Ubuntu/8.10 (intrepid) Firefox/3.0.4

Ten wykrzyknik nie jest zbędny, on ma tam być...
helios
 
Posty: 217
Z nami od: 10 sierpnia 2005, 18:15
Lokalizacja: Gdańsk


Wróć do Standardy WWW i źle działające strony

Kto jest online

Zarejestrowani użytkownicy: Bing [Bot], Google [Bot]

Przejdź do powiązanej strony

Nawigacja:

Stopka: