MozillaPL.org - polskie centrum Mozilli

Główne menu:

Menu rozwijane - błąd css? java?

Dyskusje na temat standardów WWW i zgłoszenia stron niedziałających poprawnie w przeglądarkach z rodziny Mozilli (w tym Mozilla Firefox)

Moderator: Pomocy?!

Menu rozwijane - błąd css? java?

Postautor: spider-p » 23 stycznia 2009, 09:39

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5

Witam!
Po raz pierwszy odzywam się na forum, zawsze wcześniej wyszukiwarka mnie nie zawodziła. Tym razem proszę o pomoc.
Mam problem z menu rozwijanym. Przykładowa strona: http://www.stfz.art.pl/targi-midora.html. Skrypt jest napisany podobno pod Mozillę, java jest uzupełnieniem dla IE (problemy z hover). W IE działa dobrze, w Mozilli menu się nie rozwija :-(
Zrobiłem valiadację arkusza css, standardową diagnostykę. Przeszukałem solidnie forum.
Bardzo proszę o pomoc.
Mariusz
spider-p
 
Posty: 5
Z nami od: 23 stycznia 2009, 09:05

Postautor: Tomek » 23 stycznia 2009, 15:08

Przeglądarka: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.3) Gecko/2008092515 Ubuntu/8.10 (intrepid) Firefox/3.0.3

A walidację kodu html???
"Mym sojusznikiem jest Moc, i potężnym sojusznikiem ona jest." -- Mistrz Yoda
Tomek
Moderator
 
Posty: 9049
Z nami od: 19 sierpnia 2004, 06:52

Postautor: spider-p » 23 stycznia 2009, 15:16

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5

Również, są drobne błędy, ale nie powinny wpływać na istotę problemu. Tak myślę...
Mariusz
spider-p
 
Posty: 5
Z nami od: 23 stycznia 2009, 09:05

Postautor: Tomek » 23 stycznia 2009, 16:17

Przeglądarka: Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.9.0.5) Gecko/2008121622 Ubuntu/8.10 (intrepid) Firefox/3.0.5

Skoro uważasz że niepozamykane znaczniki mogą nie mieć wpływu na istotę problemu... to mamy problem. Nikt nie będzie poprawiał twojego kodu żeby wyeliminować potencjalne błędy.
"Mym sojusznikiem jest Moc, i potężnym sojusznikiem ona jest." -- Mistrz Yoda
Tomek
Moderator
 
Posty: 9049
Z nami od: 19 sierpnia 2004, 06:52

Postautor: spider-p » 23 stycznia 2009, 16:43

Przeglądarka: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; GTB5)

Moderatorze!
Przecież nie proszę o poprawianie kodu! Uprzejmie proszę o podpowiedź w sprawie css i js!
Mariusz
spider-p
 
Posty: 5
Z nami od: 23 stycznia 2009, 09:05

Postautor: spider-p » 23 stycznia 2009, 17:10

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5

Przygotowałem plik, w którym już nic więcej nie ma poza przykładem: http://www.stfz.art.pl/targi-midora2.html. W IE działa, w FF nie!
Nadal bardzo proszę życzliwą osobę o pomoc.
Mariusz
spider-p
 
Posty: 5
Z nami od: 23 stycznia 2009, 09:05

Postautor: eldejar » 08 kwietnia 2009, 21:39

Przeglądarka: Opera/9.63 (Windows NT 5.1; U; pl) Presto/2.1.1

spider-p pisze:Przygotowałem plik, w którym już nic więcej nie ma poza przykładem: http://www.stfz.art.pl/targi-midora2.html. W IE działa, w FF nie!
Nadal bardzo proszę życzliwą osobę o pomoc.
Mariusz


mam podobny problem.. tylko chyba napisałem w złym miejscu
(zarejestrowałem się tylko po to aby uzyskać jakąkolwiek pomoc)

http://mozillapl.org/forum/post-183060.html#183060
eldejar
 
Posty: 3
Z nami od: 08 kwietnia 2009, 21:21

brak porady

Postautor: spider-p » 09 kwietnia 2009, 08:03

Przeglądarka: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; GTB5; InfoPath.2)

Witaj eldejar
Rozumiem Twój problem, gdyż sam prosiłem moderatora o pomoc, której nie otrzymałem :-( Poza bardzo "mądrymi połajankami"...

W moim wypadku problem polegał na braku jednej spacji w aplecie java. Kolega pokazał mi błąd w ciągu 30 sekund. A tu - jak widać - brak czasu na radę, nie brak czasu na pouczenia... Moderator woli się krzywić niż pomagać. Może czas na zmianę moderatora? Bo o swojej roli na forum ma chyba mylne pojęcie !

Widzę, że Twój problem już rozwiązany :-). Pozdrawiam serdecznie!
Mariusz
spider-p
 
Posty: 5
Z nami od: 23 stycznia 2009, 09:05

Postautor: Tomek » 09 kwietnia 2009, 12:55

Przeglądarka: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.8) Gecko/2009033100 Ubuntu/9.04 (jaunty) Firefox/3.0.8

@spider-p - rolą moderatora jest pilnowanie porządku i pewnych reguł. Jedną z podstawowych reguł panujących w dziale Standardy www jest przygotowanie przez pytającego poprawnego kodu html - czyli zgodnego ze standardami (Co zrobić gdy strona wyświetla się niepoprawnie? 10 kroków - pkt 1-4 - i to nie ja pisałem te zasady) . Dopiero kod strony która nie ma PODSTAWOWYCH błędów jest analizowany pod względem błędów - inaczej błądzimy we mgle. A błędy w HTML zawsze wpływają na interpretację CSS i JS - zwłaszcza niepozamykane znaczniki. Więc poprawienie ich jest podstawą przy rozwiązaniu problemu z CSS i JS. Nie zrobiłeś tego - więc założyłem że poradziłeś sobie z problemem w inny sposób. Nie poprawimy za ciebie całej strony - nie tym zajmuje się to forum.

//edit:
spiedr-p pisze:W moim wypadku problem polegał na braku jednej spacji w aplecie java.

ALE TAM NIE MA APLETU JAVA! Mylicie podstawowe pojęcia...
"Mym sojusznikiem jest Moc, i potężnym sojusznikiem ona jest." -- Mistrz Yoda
Tomek
Moderator
 
Posty: 9049
Z nami od: 19 sierpnia 2004, 06:52

Postautor: Grzegorz » 09 kwietnia 2009, 23:53

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 6.0; pl; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3 (.NET CLR 3.5.30729)

Dodam tylko, że jak ktoś potrafi skonfigurować Firefoka czy inny program ze stajni Mozilli. Pomóc znaleźć odpowiedni dodatek czy rozwiązać problem z przeglądarką, to nie musi być jednocześnie mistrzem webmasterki czy programowania.

Są specjalistyczne fora poświęcone takim właśnie rzeczom, warto pytać we właściwym miejscu. Nie wątpię, że część forumowiczów i moderatorów dobrze gotuje, a jednak nie będę tutaj pytał o przepis na zupę pomidorową.
GnuPG. Podpisuję własne wypowiedzi. | TrueCrypt. Ufam kryptografii, nie państwu. | Tor. Dbam o swoją prywatność. | OTR. Moje rozmowy nie są podsłuchiwane.

Załóż konto lub kup domenę WWW z linka polecającego: http://www.hekko.pl/?ref=34295
Grzegorz
Moderator
 
Posty: 7493
Z nami od: 15 kwietnia 2007, 12:33


Wróć do Standardy WWW i źle działające strony

Kto jest online

Zarejestrowani użytkownicy: Google [Bot]

Przejdź do powiązanej strony

Nawigacja:

Stopka: