MozillaPL.org - polskie centrum Mozilli

Główne menu:

Błąd rozwijania strony pod FF

Dyskusje na temat standardów WWW i zgłoszenia stron niedziałających poprawnie w przeglądarkach z rodziny Mozilli (w tym Mozilla Firefox)

Moderator: Pomocy?!

Błąd rozwijania strony pod FF

Postautor: expedit » 01 maja 2010, 16:18

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 6.0; pl; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729) FirePHP/0.4

Na wstępie witam wszytkich.

Mam z pozoru banalny problem, na który niestety nie znalazłem odpowiedniego tematu na forum.
Budowałem już dość skomplikowane szablony, jednak poległem na prostym problemie ( możliwe że po prostu coś przeoczyłem ) i walczę z nim już drugi dzień.

Otóż po stworzeniu szablonu całość ładnie się rozwija, dopóki nie umieszczę kolumny lewej i prawej w projekcie, jeśli lewa kolumna ma ustawiony parametr na float: none to wszystko jest ok i całość rozwija się w dół, ale niestety tak nie może być bo nie mam jak umieścić kolumny prawej.

Pod IE7 wszytko ładnie działa, "drzewa" jako tło są na dole i wszytko się ślicznie rozwija, pod FF niestety nie.

Przepraszam za zawracanie głowy tak banalnym pytaniem, jednak po prostu zawiesiłem się na tym problemie i nie mogę go przejść. A podobne tematy na różnych forach nie pomogły mi w rozwiązaniu problemu.

Umieściłem stronę pod tymczasowym adresem http://janikowski.nspace.pl/blad/


Pozdrawiam i z góry dziękuje za pomoc.
expedit
 
Posty: 2
Z nami od: 01 maja 2010, 16:06

Odp: Błąd rozwijania strony pod FF

Postautor: Tomek » 01 maja 2010, 19:27

Przeglądarka: Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.9.2.3) Gecko/20100402 Firefox/3.6.3

http://kurs.browsehappy.pl/CSS/Float
To nie błąd Fx - to błąd w wykorzystaniu float. Dla pocieszenia - dość powszechny.
Najprostsze rozwiązanie to umieszczenie za pływającymi obiektami elementu z ustawionym clear:both -zamyka to obszar pływania przez co tło rozciągnie się samoczynnie do nowo utworzonego elementu.
Inną metodą jest zastosowanie overflow:auto - jednak tu czasem spotyka się problemy z IE.
"Mym sojusznikiem jest Moc, i potężnym sojusznikiem ona jest." -- Mistrz Yoda
Tomek
Moderator
 
Posty: 9049
Z nami od: 19 sierpnia 2004, 06:52

Odp: Błąd rozwijania strony pod FF

Postautor: expedit » 03 maja 2010, 22:16

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 6.0; pl; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)

Dzięki wielkie za pomoc. Wszystko działa teraz bez problemu.
expedit
 
Posty: 2
Z nami od: 01 maja 2010, 16:06


Wróć do Standardy WWW i źle działające strony

Kto jest online

Zarejestrowani użytkownicy: Bing [Bot], dexter, Google [Bot]

Przejdź do powiązanej strony

Nawigacja:

Stopka: