MozillaPL.org - polskie centrum Mozilli

Główne menu:

Strona w UTF-8 w Firefox nie wyświetla polskich liter

Dyskusje na temat standardów WWW i zgłoszenia stron niedziałających poprawnie w przeglądarkach z rodziny Mozilli (w tym Mozilla Firefox)

Moderator: Pomocy?!

Strona w UTF-8 w Firefox nie wyświetla polskich liter

Postautor: mark014 » 31 sierpnia 2012, 23:06

Przeglądarka: Mozilla/5.0 (Windows NT 6.1; rv:14.0) Gecko/20100101 (9462B3CE-2854-96AC-C8E0-6B588B461BEC) Firefox/14.0.1

Witajcie. Mam swoją domową stację meteo i chciałem za pomocą gotowego skryptu w ciekawy sposób przedstawić dane w postaci wykresu. Wszystkie pliki miały być wykonane w UTF-8. Musiałem zrobić własne tłumaczenie zmieniając polskie znaki na kodowane przez UTF-8.

I jest problem, choć częściowy. W Firefoxie w zakładkach polskie litery wyświetlają się prawidłowo, ale w obrębie wykresów zamiast liter jest kod odpowiedniego znaku. Otworzyłem stronę w IE i tu jest wszystko OK - wszędzie polskie litery wyświetlają się bez problemów. Podobny problem z kodowaniem zachodzi w Operze.
Jest tylko jeden plik z tłumaczeniem i np. wyraz "wilgotność" też pojawia się w pliku language.php raz, ale tylko w zakładkach wyświetla się prawidłowo. Trochę się już nad tym męczyłem, ale bez skutku.

Będę wdzięczny za jakieś rady lub sugestie :) Adres strony: http://pogodaslesin.cba.pl/wugraphs.php
mark014
 
Posty: 1
Z nami od: 31 sierpnia 2012, 22:38

Wróć do Standardy WWW i źle działające strony

Kto jest online

Zarejestrowani użytkownicy: Google [Bot]

Przejdź do powiązanej strony

Nawigacja:

Stopka: