MozillaPL.org - polskie centrum Mozilli

Główne menu:

Nieprawidłowe wyświetlanie fontów na zagranicznych stronach

Dyskusje na temat standardów WWW i zgłoszenia stron niedziałających poprawnie w przeglądarkach z rodziny Mozilli (w tym Mozilla Firefox)

Moderator: Pomocy?!

Nieprawidłowe wyświetlanie fontów na zagranicznych stronach

Postautor: maru » 11 listopada 2013, 10:41

Przeglądarka: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0

Witam,

Mój problem dotyczy "krzaczków" zamiast normalnych czcionek na niektórych stronach (z tego co zauważyłem zazwyczaj dotyczy to amerykańskich serwerów, ale nie wiem czy ma to jakieś znaczenie). Dzieje się tak od kilku wersji FF wstecz, nie pamiętam dokładnie od której. Oto przykłady z tumblr.com (dzieje się tak również na blogach w tym serwisie) oraz mail otrzymany przeze mnie od nadawcy z USA (jak widać konto mailowe ma na yahoo.com). Nie mam takich problemów z innymi mailami na gmail.com.

http://s16.postimg.org/6ptvwy7kl/gmail.jpg

http://s16.postimg.org/5z15r6579/tumb1.jpg

http://s16.postimg.org/6r8f43ys5/tumb2.jpg

Znalazłem dwa sposoby na obejście tego problemu:

-widok > styl strony > ignoruj

lub

-narzędzia > opcje > treść > zaawansowane > odznaczyć "pozwalaj stronom..."

Jednak takie rozwiązania nie nadają się na dłuższą metę.

Mój system:
Win7 pl 64-bit
Firefox 25.0

Proszę o pomoc w zdiagnozowaniu przyczyn i rozwiązaniu problemu.
maru
 
Posty: 4
Z nami od: 11 listopada 2013, 10:21

Odp: Nieprawidłowe wyświetlanie fontów na zagranicznych stro

Postautor: dexter » 12 listopada 2013, 10:21

Przeglądarka: Mozilla/5.0 (Windows NT 5.1; rv:28.0) Gecko/20100101 Firefox/28.0

Usunięcie pamięci podręcznej nie pomaga?
dexter
Moderator
 
Posty: 7976
Z nami od: 02 października 2004, 21:30

Odp: Nieprawidłowe wyświetlanie fontów na zagranicznych stro

Postautor: maru » 13 listopada 2013, 16:13

Przeglądarka: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0

Nie pomaga:
-usunięcie pamięci podręcznej ani żadnej innej/wszystkich pozycji z shift+ctrl+del
-restart przeglądarki/komputera
-przeinstalowanie przeglądarki
-zmiana zestawu znaków

Nie mam tego problemu pod IE.
maru
 
Posty: 4
Z nami od: 11 listopada 2013, 10:21

Odp: Nieprawidłowe wyświetlanie fontów na zagranicznych stro

Postautor: placek77 » 13 listopada 2013, 22:19

Przeglądarka: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.0.0 Safari/537.36

zmień kodowanie przeglądarki, w tym zainstalowanie odpowiedniego słownika (w firefox)
placek77
 
Posty: 3
Z nami od: 13 listopada 2013, 22:10

Odp: Nieprawidłowe wyświetlanie fontów na zagranicznych stro

Postautor: dexter » 13 listopada 2013, 22:31

Przeglądarka: Mozilla/5.0 (Windows NT 6.0; rv:27.0) Gecko/20100101 Firefox/27.0

Bez sensu.

Na tumblr.com z menu wybierz Dla twórców witryn -> Inspektor.

Potem wybierz jakiś element, np ten z napisem "Obserwuj blogi, o których się mówi. Publikuj to, co lubisz najbardziej." i w Regułach wyłącz regułę font: 14px/1.4 "Helvetica Neue","HelveticaNeue",Helvetica,Arial,sans-serif; color: #444;

Czy napis się pojawił?
dexter
Moderator
 
Posty: 7976
Z nami od: 02 października 2004, 21:30

Odp: Nieprawidłowe wyświetlanie fontów na zagranicznych stro

Postautor: maru » 14 listopada 2013, 11:40

Przeglądarka: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0

Tak, napisy się pojawiają. Uszkodzona czcionka?
maru
 
Posty: 4
Z nami od: 11 listopada 2013, 10:21

Odp: Nieprawidłowe wyświetlanie fontów na zagranicznych stro

Postautor: dexter » 14 listopada 2013, 11:48

Przeglądarka: Mozilla/5.0 (Windows NT 5.1; rv:28.0) Gecko/20100101 Firefox/28.0

Jeżeli "Helvetica Neue" istnieje w systemie, lecz jest zrypana, to może się to tak objawiać. Gdyby jej brakowało, użyłby kolejnej na liście.

A więc skasuj z systemu "Helvetica Neue", zobaczymy co się stanie. Wcześniej obejrzyj ją w jakimś podglądzie, czy ma wszystkie literki.
dexter
Moderator
 
Posty: 7976
Z nami od: 02 października 2004, 21:30

Odp: Nieprawidłowe wyświetlanie fontów na zagranicznych stro

Postautor: maru » 14 listopada 2013, 11:54

Przeglądarka: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0

Po wywaleniu z systemu wszystkich czcionek zaczynających się od "helvetica" strony wyświetlają się poprawnie. Wielkie dzięki. Teraz tylko wystarczy znaleźć "normalną" helvetikę. :)
maru
 
Posty: 4
Z nami od: 11 listopada 2013, 10:21


Wróć do Standardy WWW i źle działające strony

Kto jest online

Zarejestrowani użytkownicy: Bing [Bot], Google [Bot]

Przejdź do powiązanej strony

Nawigacja:

Stopka: