MozillaPL.org - polskie centrum Mozilli

Główne menu:

Nowy system www.bph.pbk.pl

Dyskusje na temat standardów WWW i zgłoszenia stron niedziałających poprawnie w przeglądarkach z rodziny Mozilli (w tym Mozilla Firefox)

Moderator: Pomocy?!

Postautor: zwierz » 21 stycznia 2004, 22:08

Przeglądarka: Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.6b) Gecko/20031210

Grzegorz_P pisze:Mialem ten sam problem, poradzilem sobie w nastepujacy sposob: :evil:
Prawdopodobnie przyczyna jest brak automatycznej instalacji pluginu podpisu w wersji Mozilla 1.6 [w 1.5 robi to bez problemu]:
trzeba sciagnac na dysk plik z: https://www.bphpbk.pl/pi/components/Sig ... nstall.xpi :wink:
i zainstalowac z przegladarki, po tym problem ustepuje jak reka odjal [mozna wykonywac wszystkie opcje wlacznie z przelewami]
powodzenia :D

Hmmm. Ja nieczego nie instalowałem (a mam Mozillę 1.6b), a w miejscu KOMPONENT mam OK (tylko to jest do Javy). Co robi ten ich xpi? Ma jakiś negatywny wpływ na pracę Mozilli w Linuksie? Czy ktoś już sprawdził?
zwierz
Moderator
 
Posty: 1914
Z nami od: 31 sierpnia 2003, 10:13
Lokalizacja: Kraków

Postautor: wariat » 22 stycznia 2004, 03:02

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

Zciagnalem to co wyzej ... "polozylem" na mozille i ... tez sie wykwekla errorem atk jak z automaga ... any ideas? Bo musze karte splacic niedlugo :>
Lepszy kiepski MOTYW dla Ognistego Lisa, niż najpiękniejsza skórka Pandy Małej - www.firefox.pl
<b>wARIAT (Mozilla 0.6-MozillaPL 1.6, FireFox pl-PL 0.8-1.0, Thunderbird pl-PL 0.7)</b>
Magazyn LOOP
wariat
 
Posty: 720
Z nami od: 09 maja 2002, 20:01
Lokalizacja: Poznan

Postautor: wariat » 25 stycznia 2004, 17:05

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

Sposobem okazalo sie faktycznie zainstalowanie MoziPL 1.5 ... komponentos sie zainstalowal, pozniej wystarczylo skopiowac oba pliki do /plugins/ w zainstalowanej 1.6 ...
Teraz problem/pytanie ... czy jest tu ktos z Mozilla.org 1.6 kto mog;lby sprawdzic jak dziala zeby bylo wiadomo gdziejest blad czy wogule w 1.6 czy tylko w MozillaPL 1.6...
Lepszy kiepski MOTYW dla Ognistego Lisa, niż najpiękniejsza skórka Pandy Małej - www.firefox.pl
<b>wARIAT (Mozilla 0.6-MozillaPL 1.6, FireFox pl-PL 0.8-1.0, Thunderbird pl-PL 0.7)</b>
Magazyn LOOP
wariat
 
Posty: 720
Z nami od: 09 maja 2002, 20:01
Lokalizacja: Poznan

Postautor: zwierz » 25 stycznia 2004, 20:44

Przeglądarka: Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.6b) Gecko/20031210

wariat pisze:Sposobem okazalo sie faktycznie zainstalowanie MoziPL 1.5 ... komponentos sie zainstalowal, pozniej wystarczylo skopiowac oba pliki do /plugins/ w zainstalowanej 1.6 ...
Teraz problem/pytanie ... czy jest tu ktos z Mozilla.org 1.6 kto mog;lby sprawdzic jak dziala zeby bylo wiadomo gdziejest blad czy wogule w 1.6 czy tylko w MozillaPL 1.6...

Wreszcie udało mi się zrobić przelew. Pod Mozillą 1.6b. I nie instalowałem żadnych XPI od nich. Po prostu odpaliłem i poszło.
Nareszcie!
zwierz
Moderator
 
Posty: 1914
Z nami od: 31 sierpnia 2003, 10:13
Lokalizacja: Kraków

Postautor: zwierz » 25 stycznia 2004, 22:25

Przeglądarka: Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.6b) Gecko/20031210

Jeszcze jedno. Na mozillapl.org w dziale E-banki jest:
mozillapl.org pisze:BPH BPH Sez@am bd. Mozilla 1.6 +/+/-/+ 11 stycznia 2004 Serwis bankowy został zaktualizowany.

Zniknęła mi sprzed oczu informacja co oznaczają plusy i ten minus.
Kilka informacji ode mnie:
1. Szyfrowanie RC4 128 bitowe
2. Oficjalna data aktualizacji systemu to miał być 18.01 (mam na myśli wersję systemu dla wszystkich klientów, a nie tylko nowych), natomiast jeszcze 23.01 nie mogłem wykonać przelewu. Dziś (25.01) już mogę (i niczego od BPH-u nie musiałem instalować)
3. Wymagania:
a) Akceptacja Cookies
b) Java RE (do przelewów)
c) Javascript

Testowane: Mozilla 1.6b, Linux, Java 1.4.2_01-b06
Działa też w Operze 7.23.
zwierz
Moderator
 
Posty: 1914
Z nami od: 31 sierpnia 2003, 10:13
Lokalizacja: Kraków

Postautor: wariat » 27 stycznia 2004, 13:16

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

inwazyjny pisze:23.01 nie mogłem wykonać przelewu. Dziś (25.01) już mogę (i niczego od BPH-u nie musiałem instalować)

A mozesz zobaczyc czy masz w plugins/ jakies npsign*.*?
Lepszy kiepski MOTYW dla Ognistego Lisa, niż najpiękniejsza skórka Pandy Małej - www.firefox.pl
<b>wARIAT (Mozilla 0.6-MozillaPL 1.6, FireFox pl-PL 0.8-1.0, Thunderbird pl-PL 0.7)</b>
Magazyn LOOP
wariat
 
Posty: 720
Z nami od: 09 maja 2002, 20:01
Lokalizacja: Poznan

Postautor: zwierz » 27 stycznia 2004, 19:38

Przeglądarka: Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.6b) Gecko/20031210

wariat pisze:
inwazyjny pisze:23.01 nie mogłem wykonać przelewu. Dziś (25.01) już mogę (i niczego od BPH-u nie musiałem instalować)

A mozesz zobaczyc czy masz w plugins/ jakies npsign*.*?

Mam tylko plugin flash i dowiązanie do javy.
zwierz
Moderator
 
Posty: 1914
Z nami od: 31 sierpnia 2003, 10:13
Lokalizacja: Kraków

Postautor: wariat » 28 stycznia 2004, 03:39

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

inwazyjny pisze:Mam tylko plugin flash i dowiązanie do javy.

Czyli albo pod linuxem ten plugin nie jest potrzebny albo cos zmienili jeszce ... przy chwili zcasu przeinstaluje Mozi od nowa i zobacze co sie dzieje.
Lepszy kiepski MOTYW dla Ognistego Lisa, niż najpiękniejsza skórka Pandy Małej - www.firefox.pl
<b>wARIAT (Mozilla 0.6-MozillaPL 1.6, FireFox pl-PL 0.8-1.0, Thunderbird pl-PL 0.7)</b>
Magazyn LOOP
wariat
 
Posty: 720
Z nami od: 09 maja 2002, 20:01
Lokalizacja: Poznan

Postautor: iskierkac » 28 stycznia 2004, 09:21

Przeglądarka: Mozilla/5.0 (Windows; U; Win98; PL; rv:1.6) Gecko/20040113

Hej,
Ja mam podobne problemy co wy.
Tzn w domu jeśli chodzi o stronę bphpbk wszystko jest ok. W pracy natomiast pracuje na mozilla i szczerze mówią nie bardzo sie znam na kompach. Potrzebuję miec dostęp to konta także z pracy.
Jeśli komuś nie sprawi to problemu to prosze o instrukcję krok po kroku co i jak zrobić zeby było dobrze.
Ja sie naprawde nie znam więc prosze o wyrozumiałość
pozdr
iskierka
iskierkac
 

Postautor: wariat » 30 stycznia 2004, 12:04

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

iskierkac pisze:Hej,
Jeśli komuś nie sprawi to problemu to prosze o instrukcję krok po kroku co i jak zrobić zeby było dobrze.
iskierka

Wychodzi na to, ze nadal nie dziala w 1.6 pod windows.
Ustalmy jedno ... po probie zalogowania pojawia sie alert ze trzeba zainstralowac jakis komponent i chwile pozniej MOzilla sie wywraca. Jesli jest w ten sposob to narazei jedyne rozwiazanei zostalo podane kawalek wyzej.

1. Odinstalowac Mozilla 1.6
2. Zainstalowac Mozilla 1.5
3. Zalogowac sie w BHP
4. Wylogowac sie z Banku, wylaczyc Mozille i chwile dziwic sie, ze teraz dziala :-)
5. Skopiowac pliki C:\Program Files\mozilla.org\Mozilla\Plugins\NPSignPlugin.dll i npsign.xpt w jakies bezpieczne miejsce (np na pulpit :-)
6. Odinstalowac Mozilla 1.5
7. Zainstalowac Mozilla 1.6
8. Skopiowac obydwa pliki na miejsce, czyli do C:\Program Files\mozilla.org\Mozilla\Plugins\
9. Jarnac Mozille i zalogowac sie do banku ... powinno smigac

Odinstalowanie i instalowanie Mozilli nie powoduje utraty prywatnych danych (hasla, poczta, zakladki, etc.) usuwa jednak wszystkie zainstalowane w Mozilli dodatki.
Lepszy kiepski MOTYW dla Ognistego Lisa, niż najpiękniejsza skórka Pandy Małej - www.firefox.pl
<b>wARIAT (Mozilla 0.6-MozillaPL 1.6, FireFox pl-PL 0.8-1.0, Thunderbird pl-PL 0.7)</b>
Magazyn LOOP
wariat
 
Posty: 720
Z nami od: 09 maja 2002, 20:01
Lokalizacja: Poznan

Postautor: zwierz » 30 stycznia 2004, 20:12

Przeglądarka: Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.6b) Gecko/20031210

wariat pisze:1. Odinstalowac Mozilla 1.6
2. Zainstalowac Mozilla 1.5
3. Zalogowac sie w BHP
4. Wylogowac sie z Banku, wylaczyc Mozille i chwile dziwic sie, ze teraz dziala :-)
5. Skopiowac pliki C:\Program Files\mozilla.org\Mozilla\Plugins\NPSignPlugin.dll i npsign.xpt w jakies bezpieczne miejsce (np na pulpit :-)
6. Odinstalowac Mozilla 1.5
7. Zainstalowac Mozilla 1.6
8. Skopiowac obydwa pliki na miejsce, czyli do C:\Program Files\mozilla.org\Mozilla\Plugins\
9. Jarnac Mozille i zalogowac sie do banku ... powinno smigac

Naprawdę pod Windows trzeba tyle zachodu? Kurcze, jak ja się cieszę, że mam tego Linuksa :lol:
zwierz
Moderator
 
Posty: 1914
Z nami od: 31 sierpnia 2003, 10:13
Lokalizacja: Kraków

BPH zmienia się o 180 stopni?

Postautor: zwierz » 31 stycznia 2004, 10:14

Przeglądarka: Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.6b) Gecko/20031210

BPH zmienia się o 180 stopni? To moja reakcja na to:
https://sezam.pl/pomocba/konf_netscape_en_6.html?p=0|2
(obrazkowa konfiguracja skrzynki pocztowej w Netscape/Mozilli)
zwierz
Moderator
 
Posty: 1914
Z nami od: 31 sierpnia 2003, 10:13
Lokalizacja: Kraków

Postautor: wariat » 03 lutego 2004, 20:36

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

inwazyjny pisze:
wariat pisze:...
9. Jarnac Mozille i zalogowac sie do banku ... powinno smigac

Naprawdę pod Windows trzeba tyle zachodu? Kurcze, jak ja się cieszę, że mam tego Linuksa :lol:

Wiesz sprawa wydaje sie rozbijac o to, ze MozillaPL 1.6 lub cala mozilla 1.6 ma cos spierdzielone i wysypuje sie na instalacji komponentu ...
W 1.5 jak widac tego BUGa nie bylo i komponent instaluje sie sam bez klopotu ...
Lepszy kiepski MOTYW dla Ognistego Lisa, niż najpiękniejsza skórka Pandy Małej - www.firefox.pl
<b>wARIAT (Mozilla 0.6-MozillaPL 1.6, FireFox pl-PL 0.8-1.0, Thunderbird pl-PL 0.7)</b>
Magazyn LOOP
wariat
 
Posty: 720
Z nami od: 09 maja 2002, 20:01
Lokalizacja: Poznan

Znowu problemy

Postautor: zwierz » 05 lutego 2004, 16:16

Przeglądarka: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040204 Firebird/0.7+

Coś im się schrzaniło z:
Rachunki > Lista
Rachunki > Historia
Link nie otwiera się w ramce, jak do tej pory, tylko otwiera się sama ramka. Uniemożliwia t dalszą nawigację - > znika menu. Na szczęście w BPH "wstecz" nie powoduje wylogowania.
Jest też problem z obłsugą dwóch kont na raz w jednej przeglądarce. Dane się mieszają (to chyba zasługa cookies)
zwierz
Moderator
 
Posty: 1914
Z nami od: 31 sierpnia 2003, 10:13
Lokalizacja: Kraków

podsumowanie i instrukcja instalacji

Postautor: Kion » 05 lutego 2004, 21:53

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl-PL; rv:1.6) Gecko/20040113

Witam.
A więc sprawa wygląda następująco. Zeby uruchomić bank https://www.bphpbk.pl pod mozillą 1.6 PL i systemem WindowsXP wymagane są dwa komponenty:
SignPluginInstall.xpi
j2re-1_4_2_03-windows-i586-p.exe

Jeśli chodzi o tą drugą rzecz to sprawa jest prosta
Problem stanowi instalacja komponentu SignPluginInstall.xpi
Podczas instalacji tegoż pliku mozilla wywala się.
Można to obejść w następujący sposób:
1.Zainstalować MozillaFirebird-PL-Windows-Installer-Build-ID-0.7.exe
2. Uruchomić bankowość online
3. Zaakceptować instalację pluginu pod firebirdem
4. Przejść do katalogu, w którym zainstalowaliśmy Firebirda
5. Wejść do katalogu Plugins
6. Skopiować dwa pliki npsign.xpt i NPSignPlugin.dll do katalogu Mozilla|Plugins
7. Uruchomić i cieszyć się wszystkim


PS. Wystarzy więc mieć dwa pliki w/w i wkopiować je do katalogu plugins
Mam je u siebie na dysku. Jeśli ktoś wie gdzie je umieścić, to proszę o informację

link do plików
www.kion69.neostrada.pl

własnie robię stronę więc proszę o chwile cierpliwości
Kion
 

Dajcie mi czołg!

Postautor: zwierz » 24 lutego 2004, 16:44

Przeglądarka: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8

Wraca stare?

Dziś BPH znów mnie rozgrzał do czerwoności. Chciałem wykonać przelew.

Nie dało się dodać nowego odbiorcy.

Próbowałem się logować od nowa kilka razy. Zawsze to samo - menu "Odbiorcy" nie chciało się rozwinąć. No, ale świat się nie wali, spróbuję dalej. Wpisuję dane do przelewu, nowego odbiorcę i przechodząc do nowego pola formularza używałem tabulatora. Doszedłem do kwota przelewu, potem jest opis i

w tym momencie Firefox padł.

Próbowałem tak jeszcze dwa razy.

Zawsze w tym samym miejscu zawieszało mi przeglądarkę.

Przelew w końcu udało mi się wykonać używając do przechodzenia między polami formularza myszki. W międzyczasie kilka przelewów nie dało się wysłać, bo strona działa w oprarciu o frames i czasami

otwierał się tylko frame

z danymi do przelewu. Powodowało to niedziałanie przycisku "podpisz i wyślij".

Żeby było całkiem bosko zobaczyłem źródło strony głównej po zalogowaniu. Przestraszyłem się. Nie ma DOCTYPE, ok, to się często zdarza (choć nie powinno), nie ma kodowania polskich znaków (ok, pewnie umieścili tą informację w konkretych ramkach), ale w kodzie jest dwa razy tag "/html" i

nie ma w ogóle tagu "body",

choć jest /body. Mogę zrozumieć takie błędy u kogoś kto zrobił swoja pierwszą stronę i jeszcze nie bardzo się orientuje w temacie, ale bank?!
Dla zainteresowanych kod głównej strony (po zalogowaniu):
Kod: Zaznacz cały
<html>
<head>
   <title>System Internetowy Banku BPH</title>
   <LINK href="./css/bphpbk_t.css" type="text/css" rel="stylesheet">
</head>

<!-- frames -->

<frameset  cols="*,778,*" border="0">
    <frame name="left" src="./0/blank.html" marginwidth="0" marginheight="0" scrolling="no" frameborder="" noresize>
    <!-- START - Srodek -->

   <frameset rows="*,20,0" border="1">
              <frame name="main" src="Login?P_NO=2" marginwidth="0" marginheight="0" scrolling="auto" frameborder="0" noresize>
            <frameset  cols="50%,*,0" border="0">
                     <frame name="signature" src="ComponentsInitiator?P_COMPONENT_NAME=SIGNATORY_COMPONENT" marginwidth="0" marginheight="0" scrolling="no" frameborder="0" noresize>
                  <frame name="plugin" src="./0/blank.html" marginwidth="0" marginheight="0" scrolling="no" frameborder="0" noresize>
                  <frame name="vibfoot" src="./0/foot.html" marginwidth="0" marginheight="0" scrolling="no" frameborder="0" noresize>
            </frameset>
   </frameset>
    <!-- STOP - Srodek -->

   <frame name="right" src="./0/blank.html" marginwidth="0" marginheight="0" scrolling="no" frameborder="0" noresize>
</frameset>



</html>



</body>
</html>
zwierz
Moderator
 
Posty: 1914
Z nami od: 31 sierpnia 2003, 10:13
Lokalizacja: Kraków

Postautor: romke » 20 maja 2004, 14:24

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

wariat pisze:1. Odinstalowac Mozilla 1.6
2. Zainstalowac Mozilla 1.5
3. Zalogowac sie w BHP
4. Wylogowac sie z Banku, wylaczyc Mozille i chwile dziwic sie, ze teraz dziala :-)
5. Skopiowac pliki C:\Program Files\mozilla.org\Mozilla\Plugins\NPSignPlugin.dll i npsign.xpt w jakies bezpieczne miejsce (np na pulpit :-)
6. Odinstalowac Mozilla 1.5
7. Zainstalowac Mozilla 1.6
8. Skopiowac obydwa pliki na miejsce, czyli do C:\Program Files\mozilla.org\Mozilla\Plugins\
9. Jarnac Mozille i zalogowac sie do banku ... powinno smigac


Po wykonaniu powyższego i zalogowaniu się do systemu:
"Komponent obsługujący podpis elektroniczny jest nieaktualny.\nCzy zainstalować nową wersję?"
Po wybraniu tak, firefox (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8) wykonuje "nieprawidłową operację i zostaje zamknięty".

UPDATE: doszedłem, iż powoduje to plugin https://www.bph.pl/pi/components/SignPluginInstall.xpi - w środku opisany jako: var PLID = "@www.comarch.com/SignPlugin,version=1,0,0,29";
za co bardzo dziekuję Comarchowi :)
romke
 
Posty: 3
Z nami od: 19 sierpnia 2002, 13:59

Postautor: jasiu » 20 maja 2004, 16:06

Przeglądarka: Mozilla/5.0 (Windows; U; Win98; PL; rv:1.5) Gecko/20031007 Firebird/0.7

romke pisze:UPDATE: doszedłem, iż powoduje to plugin https://www.bph.pl/pi/components/SignPluginInstall.xpi - w środku opisany jako: var PLID = "@www.comarch.com/SignPlugin,version=1,0,0,29";
za co bardzo dziekuję Comarchowi :)


a ja bym tak nie wieszał psów na firmie Comarch. Bardzo wiele dodatków instalowanych jako XPI działa dobrze pod określoną wersją mozilli/firefoxa a pod inną nie. Muszą go zupdejtować po prostu, mniejmy nadzieje, że zrobią to w miare szybko.
jasiu
 

Postautor: Gość » 20 maja 2004, 19:37

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl-PL; rv:1.5) Gecko/20031007

jasiu pisze:
romke pisze: Muszą go zupdejtować po prostu, mniejmy nadzieje, że zrobią to w miare szybko.

To zdecydowanie wina Mozilli, a nie komponentu. Tym bardziej ze pod 1.5 i 1.7 dziala
Gość
 

Postautor: jasiu » 20 maja 2004, 21:49

Przeglądarka: Mozilla/5.0 (Windows; U; Win98; PL; rv:1.5) Gecko/20031007 Firebird/0.7

Anonymous pisze:To zdecydowanie wina Mozilli, a nie komponentu. Tym bardziej ze pod 1.5 i 1.7 dziala


Pod Win98 1.7RC2 nie działa. Może w XP/NT jest inaczej.
jasiu
 

PoprzedniaNastępna

Wróć do Standardy WWW i źle działające strony

Kto jest online

Zarejestrowani użytkownicy: Bing [Bot], dexter, Google [Bot]

Przejdź do powiązanej strony

Nawigacja:

Stopka: