MozillaPL.org - polskie centrum Mozilli

Główne menu:

zwichrowane czcionki?

Dyskusje na temat standardów WWW i zgłoszenia stron niedziałających poprawnie w przeglądarkach z rodziny Mozilli (w tym Mozilla Firefox)

Moderator: Pomocy?!

zwichrowane czcionki?

Postautor: argasek » 22 lipca 2002, 02:26

Przeglądarka: -

Witam ponownie; problem dotyczy mojej własnej strony :wink:, występuje już, z tego co zauważyłem, od Mozill 0.9.8 (wczesniej nie testowałem po prostu). Ponieważ nie bardzo nawet umiałbym opisać co się dzieje, podaję adresy dwóch screenshotów, które obrazują o co chodzi. Czcionki ulegają magicznej "zamianie" w momencie uaktywniania "pływającej ramki", czyli okna po z tekstem po prawej stronie. (Btw. wiem, że w CSSach mam niestandardowe definicje typu -scrollbar, czy -moz-opacity, ale chyba nie o to chodzi... zresztą bez nich błąd też się ujawniał). Zaznaczam, że nie dzieje się to zawsze, rzadko wręcz i niestety nie wiem jak "sprowokować" błąd w konkretny sposób; czasem udaje się to przez kliknięcie w obrębie obszaru wspomnianego IFRAME, czasem w ogóle. URLe:

http://yesterday.mylove.justdied.com/~a ... moz_ok.png

http://yesterday.mylove.justdied.com/~a ... oz_bug.png

OS: winda, Mozilla 1.0. Pod Linuxem - nie pamiętam, czy działo się coś podobnego.
Gentoo Linux 2.6.13-gentoo | http://Today.tekla.art.pl/ | JID: argasek@chrome.pl
argasek
 
Posty: 105
Z nami od: 21 lipca 2002, 21:12
Lokalizacja: Sol [0,0]

Postautor: Gandalf » 22 lipca 2002, 03:14

Przeglądarka: -

Ok. Udalo mi sie znalezc regule.

Steps to reproduce:

1) Otwieram Twoja strone.
2) Czekam az cala sie zaladuje
3) Naciskam panel po lewej
4) Wybieram "Ksiega Gosci"
5) Wpisz sie
6) Naciskam znowu "Ksiega Gosci"
7) Zaznaczam kawalek tekstu. Moze byc dowolny wpis
8) i sie zaczyna. reload i chwila zaznaczania tekstu w IFRAME daja ciekawe efekty, zmiana czcionek, cale pole biale.. roznie i ciekawie.

Dzis padam na twarz, jutro zajme sie bledem, przejdziemy na mantis a ja popatrze co to moze byc. Jesli znajdziesz latwiejszy sposob odtworzenia bledu to bede wdzieczny :)
Gandalf
 
Posty: 1802
Z nami od: 29 czerwca 2002, 04:37
Lokalizacja: Warszawa

Postautor: argasek » 22 lipca 2002, 03:23

Przeglądarka: -

Gandalf pisze:Ok. Udalo mi sie znalezc regule.

[ciach]
efekty, zmiana czcionek, cale pole biale.. roznie i ciekawie.

Dzis padam na twarz, jutro zajme sie bledem, przejdziemy na mantis a ja popatrze co to moze byc. Jesli znajdziesz latwiejszy sposob odtworzenia bledu to bede wdzieczny :)


Całe pole białe i różne kawałki cache'u (?) obrazków to już też widziałem, ale wybaczam akurat autorom Mozilli, bo jak mówię, to jest -moz-opacity, więc brzydkie chwyty, hehe :-) Dzięki za prześledzenie i robię to samo co Ty, 4 rano to nie jest dobra pora ;-) Jutro posiedzę na tym też.
Gentoo Linux 2.6.13-gentoo | http://Today.tekla.art.pl/ | JID: argasek@chrome.pl
argasek
 
Posty: 105
Z nami od: 21 lipca 2002, 21:12
Lokalizacja: Sol [0,0]

zgłoszone :)

Postautor: argasek » 23 lipca 2002, 00:30

Przeglądarka: -

Zgłosiłem na Mantis...
Gentoo Linux 2.6.13-gentoo | http://Today.tekla.art.pl/ | JID: argasek@chrome.pl
argasek
 
Posty: 105
Z nami od: 21 lipca 2002, 21:12
Lokalizacja: Sol [0,0]


Wróć do Standardy WWW i źle działające strony

Kto jest online

Zarejestrowani użytkownicy: Bing [Bot], Google [Bot]

Przejdź do powiązanej strony

Nawigacja:

Stopka: