MozillaPL.org - polskie centrum Mozilli

Główne menu:

pierwsze wersje Mozilla 1.00 i blad

Dyskusje na temat standardów WWW i zgłoszenia stron niedziałających poprawnie w przeglądarkach z rodziny Mozilli (w tym Mozilla Firefox)

Moderator: Pomocy?!

pierwsze wersje Mozilla 1.00 i blad

Postautor: Adrianer » 12 kwietnia 2002, 15:33

Przeglądarka: -

Do tej pory używałem Mozille 0.9.9 PL. Gdy zobaczylem ze na serwerze mozilli pojawila sie wersja 1.00 to odrazu ja sciaglem.
Mam ale taki problem (ktory pojawial mi sie juz tez w wersjach 0.9.9+): mianowicie na dole okienka mozilli pod paskiem stanu pokazuje mi sie taki tejst na czerowno i zajmuje on spora czesc okienka: <key id="key_irc" key="&ircCmd.commandkey;" command="Tasks:IRC "modifiers="acce ...itd. :evil: Da się coś z tym zrobić :cry:

Pozdrawiam,
Adrianer
adrianer@skrzynka.pl
Adrianer
 

Re: pierwsze wersje Mozilla 1.00 i blad

Postautor: GmbH » 12 kwietnia 2002, 17:09

Przeglądarka: -

Adrianer pisze:Do tej pory używałem Mozille 0.9.9 PL. Gdy zobaczylem ze na serwerze mozilli pojawila sie wersja 1.00 to odrazu ja sciaglem.
Mam ale taki problem (ktory pojawial mi sie juz tez w wersjach 0.9.9+): mianowicie na dole okienka mozilli pod paskiem stanu pokazuje mi sie taki tejst na czerowno i zajmuje on spora czesc okienka: <key id="key_irc" key="&ircCmd.commandkey;" command="Tasks:IRC "modifiers="acce ...itd. :evil: Da się coś z tym zrobić :cry:

To nie jest błąd, efekt ten jest spowodowany niezgodnością (brakiem) niektórych stringów w nowej wersji Mozilli, problem był omówiony w temacie http://www.mozillapl.org/forum/viewtopic.php?t=40

Jesli chcesz testować najnowszą Mozillę to mogę podesłać pliki językowe - ale nie do 1.0 tylko do najnowszych trunków (0.9.9+) - zresztą w zasadzie to to samo (w najnowszych trunkach mogą być dodane nowe elementy) ;)
GmbH
 
Posty: 825
Z nami od: 30 stycznia 2002, 22:38

Postautor: Adrianer » 13 kwietnia 2002, 06:55

Przeglądarka: -

Będe wdzięczny za wysłanie mi tych plików :D

Pozdrawiam,
Adrianer
adrianer@skrzynka.pl
Adrianer
 

Postautor: GmbH » 13 kwietnia 2002, 17:52

Przeglądarka: -

Adrianer pisze:Będe wdzięczny za wysłanie mi tych plików :D

Podesłane :) Miłego testowania :D
GmbH
 
Posty: 825
Z nami od: 30 stycznia 2002, 22:38

Wersje robocze

Postautor: GabrielBaines » 14 kwietnia 2002, 17:42

Przeglądarka: -

A może by tak po prostu udostępniać wersje robocze plików językowych do ściągnięcia na mozillapl?
Dla spokoju sumienia możecie dodać adnotację, że są to wersje robocze i instaluje sie je na własną odpowiedzialność. Abstrahując od tego, że i tak zawsze wszelkie oprogramowanie instaluje sie na własną odpowiedzialność :wink:

==
Gabriel
GabrielBaines
Moderator
 
Posty: 450
Z nami od: 05 marca 2002, 21:42

Postautor: Adrianer » 16 kwietnia 2002, 00:02

Przeglądarka: -

Dzięki za podesłanie :)) działają, no :oops: ...może prawie.
Pod win98 wszystko w porządku, ale pod XP ok. 30-40% tekstów jest po angielsku. Próbowałem reinstalować, w ustawieniach włanczać raz angielski raz polski ale nic. Dalej tak jest. Podejrzewam że jest to jakiś błąd...

Jeszcze jedna rzecz: na mój gust jest jakiś błąd w Mozilli ze wyświetlaniem strony www.nd4spd.de . Zobaczcie sobie tę stronę w IE i Operze, a w Mozilli. Myślałem od wersji 0.9.6 (moja pierwsza) że zostanie ten błąd usunięty a tu nic :(

Pozdrawiam,
Adrianer
Adrianer
 

Postautor: GmbH » 16 kwietnia 2002, 10:40

Przeglądarka: -

Adrianer pisze:Dzięki za podesłanie :)) działają, no :oops: ...może prawie.
Pod win98 wszystko w porządku, ale pod XP ok. 30-40% tekstów jest po angielsku. Próbowałem reinstalować, w ustawieniach włanczać raz angielski raz polski ale nic. Dalej tak jest. Podejrzewam że jest to jakiś błąd...

Tak, masz rację, w wyniku aktualizacji komponentu <tree> (do wyświetlania np. listy) moduł zmiany języka nie działa, odpowiednia łatka już jest, nie wiem czy została zaaplikowana. Tymczasem możesz wyedytować plik chrome.rdf w podkatalogu chrome katalogu z profilem Mozilli - trzeba zamienić ciąg en-US na pl-PL oraz US na PL.

Adrianer pisze:Jeszcze jedna rzecz: na mój gust jest jakiś błąd w Mozilli ze wyświetlaniem strony www.nd4spd.de . Zobaczcie sobie tę stronę w IE i Operze, a w Mozilli. Myślałem od wersji 0.9.6 (moja pierwsza) że zostanie ten błąd usunięty a tu nic :(

80% badanych nie widzi żadnej różnicy ;) Co dokładnie jest inaczej wyświetlane? Który błąd?
GmbH
 
Posty: 825
Z nami od: 30 stycznia 2002, 22:38

Postautor: Adrianer » 16 kwietnia 2002, 14:55

Przeglądarka: -

Dokładnie to chodziło mi o strone http://www.nd4spd.de/main.php3 i o to że tło jest białe, a w IE i Operze czarne
Adrianer
 

Postautor: GmbH » 16 kwietnia 2002, 17:35

Przeglądarka: -

Adrianer pisze:Dokładnie to chodziło mi o strone http://www.nd4spd.de/main.php3 i o to że tło jest białe, a w IE i Operze czarne

No to sprawa się skomplikowała bo ja mam niebieskie tło w Mozilli jak i w IE ;)
GmbH
 
Posty: 825
Z nami od: 30 stycznia 2002, 22:38

Postautor: GmbH » 16 kwietnia 2002, 17:37

Przeglądarka: -

Adrianer pisze:Dokładnie to chodziło mi o strone http://www.nd4spd.de/main.php3 i o to że tło jest białe, a w IE i Operze czarne

Btw. Może masz zaznaczone Preferencje->Wygląd->Kolory->Użyj kolorów systemowych oraz Użyj kolorów użytkownika?
GmbH
 
Posty: 825
Z nami od: 30 stycznia 2002, 22:38

Postautor: GabrielBaines » 17 kwietnia 2002, 21:32

Przeglądarka: -

GmbH pisze:
Adrianer pisze:Dokładnie to chodziło mi o strone http://www.nd4spd.de/main.php3 i o to że tło jest białe, a w IE i Operze czarne

No to sprawa się skomplikowała bo ja mam niebieskie tło w Mozilli jak i w IE ;)


Hmm, u mnie niebieskie w Konquerorze i białe w Mozilli.

Swoją droga kod strony jest po prostu tragiczny. Polecam próbę zwalidowania go walidatorem HTML na w3c: http://validator.w3.org/. Gdybym był przeglądarka, nie pokazałbym tej strony w ogóle :wink:

==
Gabriel
GabrielBaines
Moderator
 
Posty: 450
Z nami od: 05 marca 2002, 21:42

Postautor: Adrianer » 18 kwietnia 2002, 14:01

Przeglądarka: -

"Może masz zaznaczone Preferencje->Wygląd->Kolory->Użyj kolorów systemowych oraz Użyj kolorów użytkownika?"

Żadna z tych pcji nie jest zaznaczona dlatego nie wiem co jest grane :(
Adrianer
 

Postautor: GabrielBaines » 18 kwietnia 2002, 21:24

Przeglądarka: -

Adrianer pisze:Żadna z tych pcji nie jest zaznaczona dlatego nie wiem co jest grane :(

Jak to co jest grane - strona jest niepoprawnie napisana. Proponuje Ci prosty experyment:

Zapisz te strone na dysku (jako 'Web page, complete'), nastepnie otworz zapisany plik HTML w dowolnym edytorze do plików textowych (może być notepad/notatnik). Znajdź tag body (26 linijka) i dodaj # przed wartością atrybutu bgcolor. Innymi słowy zmień z:
<body bgcolor="003264" ...
na
<body bgcolor="#003264" ...
Teraz zapisz zmieniona stronę a nastepnie otwórz ja w Mozilli. Tło będzie juz niebieskie.

Jak można przeczytać w specyfikacji HTML 3.2, jeśli kolor jest podawany jako RGB, to MUSI zaczynac się od #. I w drugą strone, jeśli nie zaczyna sie od #, nie powinien być przez przeglądarki interpretowany jako RGB, lecz jako nazwa własna (white, navy etc). W tym wypadku "003264" nie jest oczywiście nazwą własna żadnego istniejącego koloru i powinno zostać zignorowane.

Tak więc pokazywanie niebieskiego tła na tej stronie jest błędem przeglądarek - jedynie Mozilli postepuje poprawnie, ignorując źle podany kolor.

Przy okazji: w HTML 4.0 atrybutu bgcolor w tagu <body> w ogóle juz nie ma.

To naprawdę smutne, że często użytkownicy uznaja poprawne zachowanie Mozilli za błąd tylko dlatego, że IE pokazuje inaczej. Z całym szacunkiem dla koncepcji standardów de facto, to na szczęście w3c, a nie błędy Internet Explorera wyznaczają standard HTML.

==
Gabriel
GabrielBaines
Moderator
 
Posty: 450
Z nami od: 05 marca 2002, 21:42

Postautor: M6 » 02 maja 2002, 00:52

Przeglądarka: -

GabrielBaines pisze:CIACH...
To naprawdę smutne, że często użytkownicy uznaja poprawne zachowanie Mozilli za błąd tylko dlatego, że IE pokazuje inaczej. Z całym szacunkiem dla koncepcji standardów de facto, to na szczęście w3c, a nie błędy Internet Explorera wyznaczają standard HTML.



OK - proponuje mały eksperyment ze stroną http://www.sarens.prv.pl
Ciekawe zachowania zarowno IE jak i Mozilli. Z tym, że ta druga to u mnie całkiem paranoicznie wyświetla tą stronę. Nie wiem dlaczego, ale właśnie Opera najpoprawniej ją wyświetla. A wszystko rozbija się o pliki *.png. Ciekawe... :)
M6
 

Postautor: GabrielBaines » 02 maja 2002, 16:57

Przeglądarka: -

Hmm, mogłbyś napisać cos więcej na temat paranoicznego wyświetalania tej strony w Mozilli? Nie wiem, jaki dokładnie był oryginalny zamysła autora strony, ale nie widzę niczego złego w sposobie, w jaki pokazuje ją Mozilla 0.9.9: przełączanie kolorów działa elegancko, obrazki w tle są cieniowane, działa nawet DHTML w menu. W czym więc problem?

==
Gabriel
GabrielBaines
Moderator
 
Posty: 450
Z nami od: 05 marca 2002, 21:42

Postautor: Vook » 02 maja 2002, 17:37

Przeglądarka: -

M6 pisze:OK - proponuje mały eksperyment ze stroną http://www.sarens.prv.pl
Ciekawe zachowania zarowno IE jak i Mozilli. Z tym, że ta druga to u mnie całkiem paranoicznie wyświetla tą stronę. Nie wiem dlaczego, ale właśnie Opera najpoprawniej ją wyświetla. A wszystko rozbija się o pliki *.png. Ciekawe... :)


Idę o zakład, że panowie z M$ po raz kolejny "zupełnie przypadkiem" zapomnieli poprawić błąd w obsłudze formatu który uważają za konkurencyjny do "ich standardu" (gif). Zupełnie jak bugi w obsłudze codeców QuickTime w MediaPlayerze - tylko po to żeby zniechęcić ludzi do używania tego formatu - "Bo to w MSIE nie działa..."
Dla mnie stronka ta wygląda zupełnie poprawnie pod Mozillą. A i HTML jest dosyć OK. Tylko na rozsądny wygląd trzeba zaczekać do końca bo tło graficzne ładuje się jako ostatnie, a na defaultowym mało co widać.
Vook
 
Posty: 3
Z nami od: 02 maja 2002, 15:45
Lokalizacja: Tarnów

Postautor: GabrielBaines » 03 maja 2002, 21:17

Przeglądarka: -

Vook pisze:Idę o zakład, że panowie z M$ po raz kolejny "zupełnie przypadkiem" zapomnieli poprawić błąd w obsłudze formatu który uważają za konkurencyjny do "ich standardu" (gif).


Troszkę przesadziłeś z tą teorią spiskową i myślę, że zakład byś przegrał. Format GIF wcale nie jest standardem Microsoftu. O ironio, można by go wręcz uznać za format konkurencji! GIF został stworzony przez firmę Compuserve, będącą od 1998 roku własnością AOL. Z kolei AOL, jak pewnie Ci wiadomo, w dużej mierze sponsoruje pracę nad Mozillą. Nota bene - jako ciekawostka - nowy browser Compuserve jest oparty o Gecko.

Sądzę, że w tym przypadku błąd w IE jest zwykłym błędem i nie ma co się tu doszukiwac polityki.

==
Gabriel
GabrielBaines
Moderator
 
Posty: 450
Z nami od: 05 marca 2002, 21:42

Postautor: LarryN » 20 maja 2002, 23:54

Przeglądarka: -

M6 pisze:
GabrielBaines pisze:CIACH...
To naprawdę smutne, że często użytkownicy uznaja poprawne zachowanie Mozilli za błąd tylko dlatego, że IE pokazuje inaczej. Z całym szacunkiem dla koncepcji standardów de facto, to na szczęście w3c, a nie błędy Internet Explorera wyznaczają standard HTML.



OK - proponuje mały eksperyment ze stroną http://www.sarens.prv.pl
Ciekawe zachowania zarowno IE jak i Mozilli. Z tym, że ta druga to u mnie całkiem paranoicznie wyświetla tą stronę. Nie wiem dlaczego, ale właśnie Opera najpoprawniej ją wyświetla. A wszystko rozbija się o pliki *.png. Ciekawe... :)


Moim zdaniem wszystko jest ok.
Mozilla 0.99 z debiana + PL.
LarryN
 
Posty: 273
Z nami od: 07 lutego 2002, 17:13


Wróć do Standardy WWW i źle działające strony

Kto jest online

Zarejestrowani użytkownicy: Bing [Bot], Google [Bot]

cron
Przejdź do powiązanej strony

Nawigacja:

Stopka: