MozillaPL.org - polskie centrum Mozilli

Główne menu:

Firefox 2 mini-FAQ

Tematy specyficzne dla przeglądarki Mozilla Firefox

Moderator: Pomocy?!

Firefox 2 mini-FAQ

Postautor: Ancestor » 26 października 2006, 18:42

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

  • Firefox 2 wyświetla przyciski zamykania kart na wszystkich kartach. Czy można przywrócić wygląd taki, jak w 1.5 - jeden przycisk po prawej stronie?

    Tak. Należy wpisać w pasku adresu about:config, odnaleźć za pomocą filtra ustawienie browser.tabs.closeButtons i kliknąć na nie dwa razy. Możemy wtedy wpisać jedną z poniższych wartości:
    • 0 - krzyżyk tylko na aktywnej karcie
    • 1 - krzyżyki na wszystkich kartach
    • 2 - brak krzyżyków
    • 3 - krzyżyk po prawej stronie Paska kart, tak jak w wersji 1.5
  • W Firefoksie 2, kiedy mam dużo kart, trzeba przewijać je strzałkami. Czy można tego uniknąć?

    Tak. Po wpisaniu w Pasku adresu about:config należy odnaleźć i dostosować następujące ustawienia:

    browser.tabs.tabMinWidth - definiuje minimalną szerokość karty, której poniżej której karty nie będą już się dalej zmniejszać i pojawią się strzałki. Łatwo się domyśleć, że ustawienie minimalnej szerokości na 0 wyłączy zupełnie przewijanie kart.
    Jeśli zmieniamy to ustawienie, warto również zainteresować się poniższym.

    browser.tabs.tabClipWidth - minimalna szerokość karty, dla jakiej wyświetlane są krzyżyki zamykające na każdej karcie. Ma to na celu uniknięcie przypadkowego zamykania kart.
  • Jak usunąć strzałkę po prawej stronie Paska kart, która wyświetla listę wszystkich otwartych kart?

    Do userChrome.css (co to jest?) dodaj następujący styl:
    Kod: Zaznacz cały
    .tabs-alltabs-stack {
      display: none;
    }

  • Jak ustawić, żeby obrazki nie były zmniejszane do wielkości okna? Odpowiednia opcja była w poprzedniej wersji, teraz nie mogę jej znaleźć.

    Rzeczywiście, to ustawienie zostało usunięte z okna opcji. Zamiast tego, planowano zapamiętywać ostatni stan czyli np. jeśli użytkownik powiększyłby obrazek, to od tego czasu obrazki od razu pokazywałyby się powiększone - i na odwrót. Jednak z jakiegoś powodu nie zrealizowano tego na czas i w rezultacie w interfejsie Firefoksa 2 nie można w żaden sposób ustawić tej opcji.

    Ale na szczęście wciąż jest ona dostępna - tylko ukryta. Należy wpisać w pasku adresu about:config, odnaleźć za pomocą filtra ustawienie browser.enable_automatic_image_resizing, kliknąć na nie dwa razy i wybrać wartość false.
  • Dlaczego w Firefoksie 2 nie działają skróty klawiaturowe na forach i innych stronach internetowych?

    Działają, zmieniła się tylko kombinacja. Teraz jest to: Shift+Alt+Klawisz.

    W poprzednich wersjach był to Alt+Klawisz (np. Alt+B - pogrubienie), jednak powodowało to konflikty z własnymi skrótami Firefoksa, które również używają Alt.
Ostatnio zmieniony 21 stycznia 2007, 23:38 przez Ancestor, łącznie zmieniany 11 razy
Ancestor
Moderator
 
Posty: 1799
Z nami od: 11 czerwca 2005, 20:25
Lokalizacja: Sopot

Postautor: Gość » 26 października 2006, 19:11

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.1) Gecko/20061024 BonEcho/2.0

Super pomysł żeby w jednym wątku były rozwiązania większości problemów jakie userzy mają z firefoxem 2.0, niektorzy nie umieją korzystać z przycisku szukaj i by zakładali coraz to nowe tematy. Mam nadzieje że bedziesz aktualizował :)
Gość
 

Postautor: Ancestor » 26 października 2006, 20:37

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

Anonymous pisze:Super pomysł żeby w jednym wątku były rozwiązania większości problemów jakie userzy mają z firefoxem 2.0, niektorzy nie umieją korzystać z przycisku szukaj i by zakładali coraz to nowe tematy. Mam nadzieje że bedziesz aktualizował :)

Mam taki zamiar.

Jeśli ktoś ma sugestie, co jeszcze powinno być dodane - zgłaszajcie poniżej.
Ancestor
Moderator
 
Posty: 1799
Z nami od: 11 czerwca 2005, 20:25
Lokalizacja: Sopot

Postautor: radek.kaba » 26 października 2006, 20:53

Przeglądarka: Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.8.1) Gecko/20061026 BonEcho/2.0

może jeszcze to:

layout.spellcheckDefault = 0 - żadnego sprawdzania - chyba, że się włączy PPM,
layout.spellcheckDefault = 1 - tylko pola <textarea> - czyli pola wielowierszowe (domyślnie),
layout.spellcheckDefault = 2 - także pola <input type="text"> - czyli jednowierszowe.


- dziwne, że jeszcze nikt od wczoraj o to nie zapytał...

Ewentualnie rozszerzyć browser.tabs.closeButtons:
0 = iksy tylko na aktywnej karcie - nawet jak są szerokie
1= iksy znikają na wąskich etykietach kart (domyślne)
2 = brak iksów
3 = jeden iks na pasku z prawej - like Fx1.5
radek.kaba
 
Posty: 260
Z nami od: 21 września 2005, 14:51

Postautor: Ancestor » 27 października 2006, 11:56

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

radek.kaba pisze:może jeszcze to:

layout.spellcheckDefault = 0 - żadnego sprawdzania - chyba, że się włączy PPM,
layout.spellcheckDefault = 1 - tylko pola <textarea> - czyli pola wielowierszowe (domyślnie),
layout.spellcheckDefault = 2 - także pola <input type="text"> - czyli jednowierszowe.


- dziwne, że jeszcze nikt od wczoraj o to nie zapytał...

I właśnie dlatego nie będę tego na razie dodawał do frequently asked questions. ;)

Ewentualnie rozszerzyć browser.tabs.closeButtons:
0 = iksy tylko na aktywnej karcie - nawet jak są szerokie
1= iksy znikają na wąskich etykietach kart (domyślne)
2 = brak iksów
3 = jeden iks na pasku z prawej - like Fx1.5

Gotowe.
Ancestor
Moderator
 
Posty: 1799
Z nami od: 11 czerwca 2005, 20:25
Lokalizacja: Sopot

Postautor: xaweryz » 27 października 2006, 17:35

Przeglądarka: Mozilla/5.0 (X11; U; Linux i686; pl; rv:1.8.1) Gecko/20061010 Firefox/2.0

Może dajcie też tutaj rozwiązanie na za wysoki pasek adresu
http://mozillapl.org/forum/post-136497.html#136497
xaweryz
 
Posty: 50
Z nami od: 23 maja 2005, 21:39

cd 'triki'

Postautor: bojer » 27 października 2006, 19:58

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.1) Gecko/20061010 Firefox/2.0

Witam.
Całkowite usunięcie tej “skubanej” strzałki z prawej strony zakładek:
.tabs-alltabs-stack { display: none !important;}
@ Ancestor
sorry ale Twój ‘trik’ nie usuwał całkowicie tej ‘strzałki’ tylko podpowiedzi o otwartych zakładkach. :D
bojer
 

Re: cd 'triki'

Postautor: Ancestor » 27 października 2006, 20:41

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

bojer pisze:Witam.
Całkowite usunięcie tej “skubanej” strzałki z prawej strony zakładek:
.tabs-alltabs-stack { display: none !important;}
@ Ancestor
sorry ale Twój ‘trik’ nie usuwał całkowicie tej ‘strzałki’ tylko podpowiedzi o otwartych zakładkach. :D

Eeee, racja. Powinienem to był przetestować zamiast zajrzeć tylko do DOMI.
Ancestor
Moderator
 
Posty: 1799
Z nami od: 11 czerwca 2005, 20:25
Lokalizacja: Sopot

Postautor: manieKMP » 28 października 2006, 05:50

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.1) Gecko/20061010 Firefox/2.0

Jeśli chodzi o tą listę otwartych kart (TUTAJ wabik się o to pytał), rozwiązaniem jest to:

/* Usuwa przycisk listy otwartych kart */
.tabs-alltabs-button, .tabs-alltabs-box, .tabs-alltabs-box-animate{
display: none !important;
}
/* Poprawia/usuwa "puste" miejsce jakie po tym przycisku pozostawało */
.scrollbutton-down, .scrollbutton-down-box, .scrollbutton-down-box-animate{
margin: 0 !important;
}


Działa też poprawnie gdy ma się ustawiony główny przycisk zamykania kart.

Pozdrawiam.
manieKMP
 
Posty: 454
Z nami od: 23 września 2006, 18:28
Lokalizacja: Bydgoszcz

cd trik

Postautor: bojer » 29 października 2006, 13:21

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.1) Gecko/20061010 Firefox/2.0

Witam
Aktywna zakładka jest podświetlona i.. jak dla mnie wystarczy.
Denerwujący pogrubiony font (którego nie cierpię..)
Dla tych, którzy mają podobne gust, dodać wpis w userChrome.css
tab[selected="true"] { font-weight: normal !important; }
bojer
 

Re: cd trik

Postautor: Olhado/256 » 29 października 2006, 19:27

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

bojer pisze:Witam
Aktywna zakładka jest podświetlona i.. jak dla mnie wystarczy.
Denerwujący pogrubiony font (którego nie cierpię..)
Dla tych, którzy mają podobne gust, dodać wpis w userChrome.css
tab[selected="true"] { font-weight: normal !important; }

"FAQ" oznacza "często zadawane pytania". O to chyba w ogóle nikt nie pytał, a już z pewnością nie często, więc po co tu to piszesz?
Pamiętaj obywatelu: WTYCZKI TO NIE TO SAMO, CO ROZSZERZENIA!
WinXP SP2
Olhado/256
Moderator
 
Posty: 3878
Z nami od: 26 września 2002, 09:47
Lokalizacja: Wrocław

Postautor: aztec » 03 listopada 2006, 10:39

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.0; pl; rv:1.8.1) Gecko/20061010 Firefox/2.0

proponuje dodac to: http://www.mozillapl.org/forum/about-23 ... pami%EA%E6

cytuje:
"Okazuje się, że zajmowanie olbrzymich ilości pamięci nie zawsze musi być uznawane za niepożądany efekt. Jak mówią programiści z Mozilla Foundation, pochłanianie RAM-u przez Firefoksa wynika z założeń projektu - dzięki tej opcji nawigacja w Internecie jest wygodniejsza.

Efekt nazywany jest niezbyt poprawnie "wyciekiem pamięci". Polega on na tym, że Firefox 1.5 przechowuje w pamięci pięć kopii ("Back-Forward cache") ostatnio odwiedzanych stron.

Niestety, powoduje to dość szybkie połykanie kolejnych megabajtów RAM-u przez przeglądarkę. Zwłaszcza, że cache uruchamiane jest osobno dla każdej kolejnej karty - łatwo zatem sprawdzić, co się stanie, jeśli otworzymy np. 20 stron i chwilę z nimi popracujemy: Firefox szybko zacznie zajmować 100 MB pamięci lub więcej.

Programiści z Mozilla Foundation powołują się na badania mówiące, iż 39 procent wszystkich przejść między stronami stanowią powroty do odwiedzanych przed chwilą witryn. Stąd takie a nie inne zachowanie przeglądarki.

Czytelnicy Slashdot.org podali jednak informację, w jaki sposób wyłączyć opcję tworzącą kłopotliwe kopie. Wystarczy ustawić set browser.sessionhistory.max_total_viewers na 0."

"Przeglądarka Firefox standardowo ustala wielkość pamięci operacyjnej przeznaczanej na pamięć podręczną stron automatycznie, na podstawie ilości wolnej pamięci. Aby arbitralnie określić wielkość pamięci do realizacji pamięci podręcznej, dodaj poniższy fragment do pliku user.js:

// Rozmiar cache'u w pamięci:
// -1 = określany dynamicznie (domyślnie), 0 = wyłączony, n = wielkość cache'u w kB
user_pref("browser.cache.memory.capacity", 4096);

Aby całkowicie wyłączyć cache w pamięci operacyjnej, dodaj poniższy fragment:

// Wyłączenie cache'u pamięciowego:
user_pref("browser.cache.memory.enable", false);"
aztec
 

Re: Firefox 2 mini-FAQ

Postautor: Dehu » 03 listopada 2006, 14:57

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.1) Gecko/20061010 Firefox/2.0

Ancestor pisze:W Firefoksie 2, kiedy mam dużo kart, trzeba przewijać je strzałkami. Czy można tego uniknąć?

Tak. Po wpisaniu w Pasku adresu about:config należy odnaleźć i dostosować następujące ustawienia:

browser.tabs.tabMinWidth - definiuje minimalną szerokość karty, której poniżej której karty nie będą już się dalej zmniejszać i pojawią się strzałki. Łatwo się domyśleć, że ustawienie minimalnej szerokości na 0 wyłączy zupełnie przewijanie kart.
Jeśli zmieniamy to ustawienie, warto również zainteresować się poniższym.

browser.tabs.tabClipWidth - minimalna szerokość karty, dla jakiej wyświetlane są krzyżyki zamykające na każdej karcie. Ma to na celu uniknięcie przypadkowego zamykania kart.


Ten sposób u mnie nie działa. Ustawiłem oba parametry na 0, ale dalej przy zbyt wielkiej ilości tabów (u mnie 27) pojawiają się strzałki do przewijania. Mam zainstalowane Tabbrowser Preferences, nie wiem, czy to ma jakiś wpływ na to.
Dehu
 

Re: Firefox 2 mini-FAQ

Postautor: Ancestor » 03 listopada 2006, 15:03

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

Dehu pisze:Ten sposób u mnie nie działa. Ustawiłem oba parametry na 0, ale dalej przy zbyt wielkiej ilości tabów (u mnie 27) pojawiają się strzałki do przewijania. Mam zainstalowane Tabbrowser Preferences, nie wiem, czy to ma jakiś wpływ na to.

Może mieć. Wyłącz to rozszerzenie i się przekonaj.
Ancestor
Moderator
 
Posty: 1799
Z nami od: 11 czerwca 2005, 20:25
Lokalizacja: Sopot

Re: Firefox 2 mini-FAQ

Postautor: Dehu » 04 listopada 2006, 12:26

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.1) Gecko/20061010 Firefox/2.0

Ancestor pisze:Może mieć. Wyłącz to rozszerzenie i się przekonaj.


Jednak nie ma... Dalej pojawiają się strzałki. Żeby się jeszcze one porządnie dały przewijać, a nie że jak za szybko klikam, to zamiast przesuwać zakładki, tworzy nowe :roll:
Dehu
 

Re: Firefox 2 mini-FAQ

Postautor: Olhado/256 » 04 listopada 2006, 12:35

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

Dehu pisze:
Ancestor pisze:Może mieć. Wyłącz to rozszerzenie i się przekonaj.

Jednak nie ma... Dalej pojawiają się strzałki. Żeby się jeszcze one porządnie dały przewijać, a nie że jak za szybko klikam, to zamiast przesuwać zakładki, tworzy nowe :roll:

Ale czemu te strzałki ci przeszkadzają? W starszych wersjach Firefoksa przy zbyt dużej liczbie otwartych kart strzałki się nie pojawiały, ale karty i tak wyłaziły poza pasek i nie można się było do nich dostać. To już chyba lepiej mieć strzałki? Szczególnie, że pasek kart możesz też przewijać rolką w myszce, nie musisz na te strzałki klikać.
Pamiętaj obywatelu: WTYCZKI TO NIE TO SAMO, CO ROZSZERZENIA!
WinXP SP2
Olhado/256
Moderator
 
Posty: 3878
Z nami od: 26 września 2002, 09:47
Lokalizacja: Wrocław

Re: Firefox 2 mini-FAQ

Postautor: Dehu » 04 listopada 2006, 22:51

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.1) Gecko/20061010 Firefox/2.0

Olhado/256 pisze:Ale czemu te strzałki ci przeszkadzają? W starszych wersjach Firefoksa przy zbyt dużej liczbie otwartych kart strzałki się nie pojawiały, ale karty i tak wyłaziły poza pasek i nie można się było do nich dostać. To już chyba lepiej mieć strzałki? Szczególnie, że pasek kart możesz też przewijać rolką w myszce, nie musisz na te strzałki klikać.


Kwestia przyzwyczajenia ;)
Dehu
 

Postautor: Ancestor » 05 listopada 2006, 13:11

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

aztec pisze:proponuje dodac to: http://www.mozillapl.org/forum/about-23 ... pami%EA%E6

[...]

To nie są rzeczy specyficzne dla Firefoksa 2, a to FAQ jest na temat nowych zmian w Fx2.
Ancestor
Moderator
 
Posty: 1799
Z nami od: 11 czerwca 2005, 20:25
Lokalizacja: Sopot

Postautor: manieKMP » 05 listopada 2006, 15:18

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.1) Gecko/20061010 Firefox/2.0

Zostało wydzielone, z tego tematu, a że poszło do innego, nie związanego z tym co poniżej, więc stamtąd część usunąłem i tu wklejam spowrotem (myślałem, że mi wykasowano odp. i nie wiedziałem dlaczego :))

Dehu, nie chcesz mieć przycisków przewijania kart, wstaw do userChrome.css to:
Kod: Zaznacz cały
/*Usuwa przyciski przewijania kart*/
.scrollbutton-up, .scrollbutton-down-stack *{
 display: none !important;
}

ale i tak będziesz zmuszony do przewijania scrollem w myszcze.

Pozdrawiam.
manieKMP
 
Posty: 454
Z nami od: 23 września 2006, 18:28
Lokalizacja: Bydgoszcz

Re: cd 'triki'

Postautor: Gość » 12 listopada 2006, 11:16

Przeglądarka: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.1) Gecko/20061010 Firefox/2.0

bojer pisze:Witam.
Całkowite usunięcie tej “skubanej” strzałki z prawej strony zakładek:
.tabs-alltabs-stack { display: none !important;}


[ort]przejżałem [/ort]cały config i takiego wpisu nie widzę. Skąd go [ort]wziełeś[/ort]?
Gość
 

Następna

Wróć do Przeglądarka Firefox

Kto jest online

Zarejestrowani użytkownicy: Google [Bot]

cron
Przejdź do powiązanej strony

Nawigacja:

Stopka: