MozillaPL.org - polskie centrum Mozilli

Główne menu:

FAQ: Thunderbird

Jeśli masz problem, który nie jest tutaj opisany, poproś o pomoc na forum.
Jednak zanim to uczynisz, koniecznie przeprowadź Standardową Diagnostykę. Za jej pomocą można poradzić sobie z większością powszechnych problemów.

Poczta przychodząca

Zapamiętywanie haseł

Aby program za każdym razem nie pytał się o hasło, wystarczy podczas wprowadzania hasła (trzeba połączyć się z serwerem) zaznaczyć opcję Użyj Menedżera haseł, aby zapamiętać to hasło.

Automatyczne pobieranie poczty

Wszystkie opcje dotyczące kont skonfigurowanych w programie ustawia się za pomocą panelu dostępnego w menu Narzędzia (lub Edycja) opcja Konfiguracja kont > nazwa konta > Ustawienia serwera.

Dla każdego konta, którego wiadomości mają być automatycznie pobierane po uruchomieniu programu, należy zaznaczyć poniższe opcje:

  • Sprawdzaj, czy są nowe wiadomości podczas uruchamiania programu
  • Automatycznie pobieraj nowe wiadomości

Ponadto, najlepiej jeśli hasła dla wszystkich takich kont zostaną zapamiętane za pomocą Menedżera haseł, tak aby program podawał je automatycznie.

Automatyczne sprawdzanie poczty co np. 2 minuty

Ustawienia częstotliwości sprawdzania nadejścia nowej poczty można zmienić w opcji Sprawdzaj, czy nadeszły nowe wiadomości co XX minut - na panelu Konfiguracja kont > nazwa konta pocztowego > Ustawienia serwera z menu Narzędzia (ew. menu Edycja).

Wazna-uwaga.png Pojęcie sprawdzania poczty nie jest równoznaczne z pobieraniem wiadomości.
(to, czy wiadomość zostanie pobrana, zależy od pozostałych ustawień programu)

Zmiana zapamiętanego hasła

Wszystkie hasła przechowywane są przez Menedżera haseł. Aby usunąć dowolne, hasło należy uruchomić Menedżera (Narzędzia > Opcje > Prywatność > Hasła > Wyświetl zapisane hasła, ew. Edycja > Preferencje i dalej tak samo), a następnie zaznaczyć wybrane do usunięcia hasło i nacisnąć Usuń (samo hasło domyślnie jest ukryte, można to zmienić wybierając pokaż hasła). Następnie trzeba połączyć się z serwerem - pobrać pocztę (dopiero podczas próby logowania na serwerze program zapyta o hasło, warto też zaznaczyć, aby zapamiętał hasło).

Wazna-uwaga.png Użyty termin zmiana hasła oznacza zmianę hasła w programie pocztowym używanego w celu uwierzytelnienia na serwerze; samo hasło nie zostanie w ten sposób zmienione.

Hasła należy ręcznie usuwać w przypadku każdej aktualizacji hasła - w przeciwnym wypadku program będzie próbował bezskutecznie zalogować się używając starego, zapamiętanego hasła (Błąd 182362 BugIcon.png).

Ograniczenie wielkości pobieranych wiadomości

W celu ograniczenia wielkości automatycznie pobieranych wiadomości do np. 2MB, należy wprowadzić maksymalny rozmiar wiadomości w ustawieniach poszczególnych kont programu. W Konfiguracji kont, w części dotyczącej danego serwera, należy wybrać panel Miejsce na dysku (lub Tryb offline dla kont IMAP i grup dyskusyjnych) i zmienić opcję Nie pobieraj wiadomości większych niż.

W przypadku serwerów poczty POP, jeśli wielkość wiadomości przekracza limit, ściągnięty zostanie tylko jej początkowy fragment. Jeśli po jego obejrzeniu zechcemy ściągnąć resztę wiadomości, należy kliknąć w odnośnik, który pojawi się w treści wiadomości wyświetlanej przez program.

Filtrowanie pobieranych wiadomości

Narzędzie pozwalające automatycznie zarządzać pocztą przychodzącą (podobne do reguł wiadomości znanych z Outlook Express) nazywa się Filtry wiadomości. Filtry można dodawać, konfigurować i usuwać przez menu Narzędzia > Filtrowanie wiadomości.

Należy również pamiętać iż reguły filtrowania ustawia się dla każdego konta (a w zasadzie folderu odebranych wiadomości) osobno poprzez wybór odpowiedniego konta z rozwijanej listy w oknie filtrów wiadomości.

Wysyłanie poczty

Wiele serwerów poczty wychodzącej

W celu wysyłania wiadomości przy pomocy różnych serwerów poczty po pierwsze należy dodać nowe serwery SMTP: Konfiguracja kont > Serwer poczty wychodzącej SMTP z menu Narzędzia (ew. Edycja), przycisk Dodaj....
Następnie w ustawieniach każdego konta Konfiguracja kont > nazwa konta > Konfiguracja konta należy nacisnąć przycisk Serwer poczty wychodzącej (SMTP), aby przypisać któryś z wcześniej skonfigurowanych serwerów poczty wychodzącej SMTP dla tego konta.

Niezależnie od tego istnieje możliwość wyboru serwera, z którego wiadomość będzie wysłana bezpośrednio podczas redagowania wiadomości (z rozwijanej listy przy polu Nadawca - o ile skonfigurowano więcej niż jeden serwer poczty wychodzącej) oraz (niezależnie) tworzenia tożsamości.

Autoryzacja czyli uwierzytelnienie

Jeżeli serwer wymaga uwierzytelnienia (podania loginu i hasła) dla wysyłanej poczty (obecnie niemal wszystkie), należy wybrać kategorię Serwer poczty wychodzącej (SMTP) na samym dole listy dostępnej z menu Narzędzia > Konfiguracja kont (ew. Edycja > Konfiguracja kont). Następnie zaznaczyć opcję: Używaj identyfikatora użytkownika oraz hasła oraz wprowadzić nazwę użytkownika. Kurier Poczty wyświetli pytanie o hasło przy pierwszej próbie wysłania wiadomości.

Wazna-uwaga.png Pojęcie "uwierzytelnianie" czy "autoryzacja" nie jest równoznaczne z szyfrowaniem transmisji.

Pole portu poczty wychodzącej

W pole do wpisania portu w konfiguracji serwera poczty wychodzącej zazwyczaj nie trzeba nic wpisywać. Standardowym portem poczty wychodzącej jest 25 (port 465 w przypadku szyfrowania SSL) i program automatycznie użyje tego portu, jeśli nie wprowadzono innego. Jeżeli dany serwer pocztowy używa niestandardowego portu, należy skontaktować się z administratorem serwera i wprowadzić podany przez niego numer portu.

Obok okienka, w którym podajemy numer portu, program podpowiada, jaki jest domyślny numer portu w danej konfiguracji. Możemy skorzystać z tej podpowiedzi, jeśli przez pomyłkę wpisaliśmy niewłaściwy numer portu.

Szyfrowanie poczty wychodzącej (SSL)

W celu szyfrowania połączenia z serwerem dla wysyłanej poczty należy wybrać kategorię Serwer poczty wychodzącej (SMTP) na samym dole listy dostępnej z menu Narzędzia > Konfiguracja kont (ew. Edycja > Konfiguracja kont). Następnie wybrać opcję TLS w sekcji Użyj szyfrowane połączenie typu. Opcja ta oznacza najczęściej spotykany na polskich serwerach sposób, tzn. nawiązanie połączenia nieszyfrowanego (przez port 25), a następnie przejście w tryb szyfrowany przez komendę STARTTLS. Jeśli natomiast nasz serwer od razu nawiązuje połączenie szyfrowane (na porcie 465), to należy wybrać opcję SSL - program automatycznie przestawi numer portu na górze tego panelu.

Żądanie potwierdzenia przeczytania listu

Aby wysłać list z żądaniem potwierdzenia, należy podczas pisania nowej wiadomości zaznaczyć opcję menu Opcje > Żądaj potwierdzenia dostarczenia wiadomości w oknie kompozytora wiadomości. Można również ustawić tę opcję na stałe globalnie (Narzędzia > Opcje > Tworzenie > Ogólne > Opcje potwierdzeń, ew. Edycja > Preferencje > i dalej tak samo) jak i osobno dla każdego z kont (w Konfiguracji kont w panelu Potwierdzenia).

Wyślij później (skrzynka nadawcza)

W Outlooku można po zakończeniu pisania listu przenieść go do Skrzynki nadawczej i po połączeniu z Internetem wysyłać wszystkie wiadomości automatycznie, czy też trzeba każdą wiadomość wysyłać osobno?

Aby skorzystać z funkcjonalności skrzynki nadawczej należy po napisaniu wiadomości wybrać opcję Wyślij później z menu Plik lub nacisnąć Ctrl+Shift+Enter. Wiadomość zostanie zachowana w katalogu Niewysłane w Folderach lokalnych (w razie potrzeby katalog zostanie utworzony automatycznie). Wiadomości z tego katalogu wysyła się przez menu Plik > Wyślij niewysłane wiadomości.

Można również przed przystąpieniem do pisania serii wiadomości przełączyć się w tryb offline (z menu Plik > Tryb offline > Pracuj w trybie offline lub ikonką w prawym dolnym rogu programu). Wtedy przycisk Wyślij w oknie tworzenia wiadomości zmienia znaczenie na Wyślij później. Po ponownym przejściu w tryb online program zapyta, czy należy wysłać wszystkie niewysłane wiadomości.

Ukrywanie adresów w wysyłanej wiadomości

W celu ukrycia adresu/ów w wysyłanej wiadomości należy w oknie tworzenia wiadomości wybrać z rozwijanej listy obok pola adres (Do:) i wybrać opcję Ukryta kopia. Należy zrobić to dla każdego wpisanego w osobnym wierszu adresata lub listy wysyłkowej.

Grupy dyskusyjne

Sortowanie listy grup w widoku drzewa folderów

Obecnie nie jest dostępna opcja sortowania listy grup dyskusyjnych (np. alfabetycznie) w panelu z lewej strony okna programu, zgłoszono już propozycję zmiany tego stanu (Błąd 97186 BugIcon.png).

Można natomiast zrobić to ręcznie, poprzez edycję pliku tekstowego .newsrc dla danego serwera. Aby dowiedzieć się, gdzie tego pliku szukać, należy zajrzeć do opcji Konfiguracja kont, pozycja Ustawienia serwera dla odpowiedniego serwera grup. Pośrodku ekranu znajduje się nazwa pliku .newsrc dla tego serwera wraz z pełną ścieżką dostępu. Przy wyłączonym programie należy otworzyć ten plik w jakimś edytorze tekstowym (np. w Notatniku) i ustawić linie z kolejnymi grupami w żądanej kolejności. Po ponownym uruchomieniu program powinien wyświetlać grupy w pożądanej przez nas kolejności.

Monitorowanie (śledzenie) wątków

W Outlooku podoba mi sie właściwie tylko jedno: monitorowana wiadomość automatycznie ustawiana jest jako pierwsza - tak w grupach newsowych, jak i w normalnej poczcie. Bardzo ułatwia to śledzenie ważnych wątków. Kiedy w Thunderbirdzie będzie podobnie?

Obserwowanie wątków na grupach dyskusyjnych jest w Thunderbirdzie nieco inaczej rozwiązane. Wątki śledzone oznacza się naciskając klawisz w, co powoduje pojawienie się innej ikonki wątku (z okiem lub okularkami). Można wybrać z menu opcję Widok > Wątki > Nieprzeczytane śledzone wątki, aby ukryć wszystkie pozostałe wiadomości.

Działanie podobne do Outlook Express można zasymulować inaczej. Obserwowane wątki należy wyróżniać nadając pierwszej wiadomości w wątku etykietę (klawiszem 1 do 5) lub oznaczając ją (menu Wiadomość > Zaznacz > Oznacz). Należy zmienić sortowanie wiadomości w grupie dyskusyjnej: Widok > Sortuj według > Etykiety (lub Oznaczenia). Jeśli stracimy w ten sposób wątkowanie, należy dodatkowo użyć Widok > Wiadomości > Wątki. W ten sposób wątki "obserwowane" będą na początku listy, a za nimi wszystkie pozostałe.

Oznaczanie grup jako przeczytanych

Nie istnieje opcja automatycznego oznaczania. Natomiast można to zrobić ręcznie. Jeśli aktywna jest grupa dyskusyjna, to na pasku narzędzi dostępny jest przycisk Zaznacz wraz z menu, za pomocą którego można zaznaczyć jako przeczytaną: bieżącą wiadomość, wątek, wiadomości według daty, lub wszystkie wiadomości w grupie dyskusyjnej. Te same czynności można wykonać za pomocą podanych w tym samym miejscu skrótów klawiaturowych lub menu Wiadomość > Zaznacz.

Logowanie do serwera news

Jeśli serwer grup dyskusyjnych wymaga logowania (czyli uwierzytelnienia, autoryzacji - podania loginu i hasła), to przy pierwszym połączeniu z serwerem (identycznie jest w przypadku serwera poczty) program wyświetli okno dialogowe, w którym należy wprowadzić nazwę użytkownika, a potem następne okno dla podania hasła. Zaznaczając odpowiednią opcję można zapamiętać to hasło na stałe, tak aby nie było konieczności wprowadzania go powtórnie.

Opcja Zawsze żądaj uwierzytelnienia podczas łączenia z tym serwerem, znajdująca się w Konfiguracja kont > nazwa serwera > Ustawienia serwera, służy do wymuszania autoryzacji nawet na tych serwerach, które nie żądają hasła, ale umożliwiają wtedy tylko ograniczony dostęp. Dla serwerów wymagających autoryzacji opcja nie musi być włączana.

Wyświetlanie wiadomości

Wyświetlanie nazwy programu nadawcy wiadomości

Nagłówki, Program pocztowy: Co zrobić, aby Thunderbird wyświetlał w nagłówku nazwę programu pocztowego nadawcy listu?

Program może informować o nazwie programu nadawcy wiadomości na kilka sposobów. Należy pamiętać, że są to informacje uzyskiwane bezpośrednio z treści wiadomości i mogą zostać łatwo zafałszowane. Najpopularniejszymi metodami są:

  • Instalacja rozszerzenia Display Mail User Agent
  • Instalacja rozszerzenia Mnenhy
  • Ręcznie; należy w głównym katalogu profilu programu stworzyć lub edytować już istniejący plik tekstowy o nazwie user.js. Aby włączyć wyświetlanie nagłówka "Program pocztowy" dodajemy do tego pliku wpis:
    user_pref("mailnews.headers.showUserAgent", true);
    Wazna-uwaga.png Wszelkie operacje na plikach konfiguracyjnych należy wykonywać przy wyłączonym programie.
    Dobrze jest też przed zmianami wykonać kopię zapasową profilu.

Wybór czcionki treści wiadomości

Ustawienia czcionek dostępne są poprzez menu (Narzędzia (ew. Edycja) > Opcje (ew. Preferencje) > Wyświetlanie > Czcionki). Do wyświetlania treści wiadomości program używa czcionki wskazanej w polu O stałej szerokości dla kodowania środkowoeuropejskiego.

W Seamonkey i Mozilli Suite ustawienia czcionek znajdują się w Edycja > Preferencje > Wygląd > Czcionki; zmiana tych ustawień wpływa również na wygląd stron WWW w Nawigatorze - w szczególności tych stron, które nie definiują własnej czcionki.

Wielopoziomowe kolorowanie cytatów

Zalecanym sposobem uzyskania efektu wielopoziomowego kolorowania cytatów (różne kolory dla cytatów, cytatów cytatów, itd.) jest instalacja rozszerzenia QuoteColors.

Takie zmiany można również wprowadzić poprzez edycję plików programu, tak jak opisano na forum MozillaPL.
Cytaty można również "zwijać"; służy do tego rozszerzenie Quote Collapse.

Nie widać daty w wiadomościach, tylko godzinę

Daty wiadomości otrzymanych lub wysłanych w danym dniu wyświetlana jest tylko w postaci godziny, następnego dnia będzie wyświetlona pełna data.

Takie zachowanie programu można zmienić za pomocą rozszerzenia ConfigDate.

Wyłączenie graficznego oznaczania cytatów

Graficzne oznaczanie cytatów można wyłączyć poprzez zmianę wartości łańcucha mail.quoted_graphical na false poprzez edytor ustawień (Narzędzia (ew. Edycja) > Opcje (ew. Preferencje) > Zaawansowane > Ogólne).

W Seamonkey i Mozilli Suite odpowiednikiem edytora ustawień jest ich lista wywoływana poprzez wpisanie w pasek adresu Nawigatora about:config.

Tworzenie wiadomości

Zmiana wrotki

Tekst pojawiający się przy odpowiadaniu na wiadomość, przed cytowanym blokiem, tzw. wrotka lub tekst wprowadzający, standardowo rozpoczyna się od: Użytkownik napisał (w wersjach angielskich "ktoś tam wrote"). Wrotkę można zmodyfikować na kilka sposobów jednak najprościej zainstalować rozszerzenie Reset Quote Header.

Automatyczne dodawanie sygnaturki pod wiadomościami

Najpierw należy utworzyć plik tekstowy z sygnaturką (np. w Notatniku). Warto dodać, że dobrym zwyczajem jest zrobienie sygnaturki nie dłuższej niż cztery linie. Nie należy dodawać na początku tego pliku tzw. delimitera (ciąg znaków "-- " [minus, minus, spacja], który pozwala programom na rozpoznanie sygnaturki i np. wycięcie przy odpowiadaniu na naszą wiadomość) - zostanie on dodany automatycznie w treści listu.

Następnie należy utworzoną sygnaturę wskazać w programie. Sygnatury przypisuje się do konta pocztowego i/lub tożsamości. Należy w tym celu:

  1. Przejść do widoku ustawień serwera: Edycja > Konfiguracja kont > Nazwa serwera poczty lub news.
  2. Zaznaczyć opcję Dołączaj sygnaturkę.
  3. Podać ścieżkę dostępu do pliku sygnatury.
Istnieją przynajmniej dwa rozszerzenia które pozwalają rozbudować mechanizm dodawania sygnatur:

Sprawdzanie pisowni w trakcie pisania

Obecnie funkcjonalność sprawdzania pisowni "na bieżąco" (z podkreślaniem błędów na czerwono) jest wbudowana w program: Opcje > Sprawdzaj pisownię w trakcie tworzenia wiadomości.

Sprawdzanie pisowni w innym języku

W tym celu należy pobrać i zainstalować nowy słownik. Najprostszą metodą jest instalacja słownika jako rozszerzenia, w tym celu należy:

  1. Przejść do Narzędzia (ew. Edycja) > Opcje (ew. Preferencje) > Tworzenie > Pisownia i wybrać odnośnik Pobierz więcej słowników
  • W programach Seamonkey i Mozilla Suite okno tworzenia wiadomości > przycisk Pisownia > z rozwijanej listy wybrać Pobierz więcej słowników.
  1. Pobrać (nie instalować) ze strony interesującą nas wersję słownika
  2. Zainstalować słownik w programie pocztowym: Narzędzia > Rozszerzenia > Instaluj > wskazać pobrany plik
  • Słowniki są instalowane do katalogu programu i z tego powodu mogą być potrzebne uprawnienia administratora aby dokonać instalacji.
  • W programach Seamonkey i Mozilla Suite słowniki można instalować bezpośrednio ze strony.

Istnieją również inne metody instalacji słowników, szczegóły w artykule Słowniki.

Redagowanie wiadomości w HTML

Program umożliwia redagowanie wiadomości w formacie HTML, umożliwiając tym samym wybór czcionki, koloru, tła czy innego zaawansowanego formatowania dla wiadomości. Warto jednak zauważyć, że takie wiadomości (szczególnie z załączoną grafiką bądź elementami pobieranymi z internetu) nie są lubiane przez większość internautów i zostaną wyświetlone jako czysty tekst (tak jak w pliku *.txt).

Tworzenie wiadomości w HTML można włączyć:

  • Globalnie: Narzędzia (ew. Edycja) > Opcje (ew. Preferencje) > Tworzenie > ogólne > Opcje wysyłania.
    • W Seamonkey i Mozilla Suite: Edycja > Preferencje > Formatowanie.
  • Globalnie dla całego konta w Konfiguracja kont > nazwa konta > Tworzenie.
  • Globalnie dla każdej tożsamości: Konfiguracja kont > nazwa konta > Zarządzaj tożsamościami > Dodaj/Edytuj > Tworzenie i adresowanie wiadomości.
  • Względem domeny: Narzędzia (ew. Edycja) > Opcje (ew. Preferencje) > Tworzenie > ogólne > Opcje wysyłania.
  • Ponadto zawsze można przełączyć rodzaj edytora, używanego do pisania wiadomości (tekstowego lub HTML) trzymając klawisz Shift przy wywoływaniu okna tworzenia nowej wiadomości.

Aby wiadomość była wysłana w HTML, trzeba odpowiednio ustawić opcje - w Seamonkey Edycja > Preferencje > Kurier Poczty > Formatowanie, w Thunderbird Narzędzia > Opcje > Tworzenie > Opcje wysyłania, a przy niektórych ustawieniach - zadbać o to, aby adresat znajdował się w książce adresowej i ustawić we właściwościach adresu Preferowany format otrzymywanych wiadomości > HTML.

Tapetę do treści listu dodajemy korzystając z opcji Format > Kolory strony i tła w oknie tworzenia wiadomości. Należy wybrać plik z tapetą w pozycji Obrazek tła.

Konfiguracja

Szyfrowanie przy pomocy kluczy PGP/GPG

Oficjalnie Thunderbird obsługuje standard ~S/MIME. Do obsługi szyfrowania i deszyfrowania wiadomości przy użyciu PGP/GPG należy zainstalować rozszerzenie EnigMail. Jego konfiguracja i użycie zostało dokładnie opisane w artykule [EnigMail].

Ustawianie kolejności kont w widoku drzewa folderów

Istnieje pewna możliwość przestawiania kolejności kont w ograniczonym zakresie. Wymaga to edycji plików konfiguracyjnych (zobacz: Zmiana kolejności wyświetlania kont).

Zobacz również

Warto również się zapoznać z:

  1. Szkoła
  2. Rozwiązywanie problemów

Przeniesiesienie na MediaWiki i korekta: Stefan Plewako 01:54, 5 cze 2006 (CDT)
Tę stronę ostatnio zmodyfikowano o 13:34, 7 lis 2007.

Osobiste:

Akcje:

:

Pomagają nam:

Przejdź do powiązanej strony

Nawigacja:

Stopka: