MozillaPL.org - polskie centrum Mozilli

Główne menu:

Słowniki


Obecnie programy Mozilli wykorzystują słowniki Aspell, daje to dość dużą dowolność w sposobach ich instalacji.

Instalacja przy pomocy rozszerzenia

Najprostszą metodą jest instalacja słownika jako rozszerzenia, w tym celu należy:

Firefox

Funkcjonalność sprawdzania pisowni w przeglądarce dostarcza obecnie rozszerzenie Spell Bound.

W wersji 2.0 Firefoksa, która ukaże się jeszcze w tym roku, moduł sprawdzania będzie już wbudowany.

Seamonkey

  1. Przejść do okna sprawdzania pisowni: Kurier Poczty > Nowa > ustawić zaznaczenie na treść > Pisownia > z rozwijanej listy wybrać Pobierz więcej
  2. Wybrać i zainstalować słownik (można bezpośrednio ze strony klikając lewym przyciskiem myszy na nazwę)
  3. Uruchomić ponownie program

Aby sprawdzać pisownię z wykorzystaniem nowo zainstalowanego słownika należy wybrać język z rozwijanej listy w oknie sprawdzania pisowni.

Thunderbird

  1. Przejść do Narzędzia (ew. Edycja) > Opcje (ew. Preferencje) > Tworzenie > Pisownia.
  2. Wybrać odnośnik Pobierz więcej słowników.
  3. Pobrać (nie instalować) ze strony interesującą nas wersję słownika na dysk (poprzez opcję Zapisz element docelowy jako... z menu kontekstowego wywoływanego prawym przyciskiem myszy przy wybieraniu odnośnika).
  4. Zainstalować słownik w Thunderbirdzie: Narzędzia > Rozszerzenia > Instaluj > wskazać pobrany plik.
    Wazna-uwaga.png Słowniki są instalowane do katalogu programu i z tego powodu mogą być potrzebne uprawnienia administratora aby dokonać instalacji.
  5. Uruchomić ponownie program.

Aby sprawdzać pisownię z wykorzystaniem nowo zainstalowanego słownika należy wybrać język z rozwijanej listy w Narzędzia (ew. Edycja) > Opcje (ew. Preferencje) > Tworzenie > Pisownia lub w oknie sprawdzania pisowni.

Instalacja słowników OpenOffice

Obecnie popularne jest również wykorzystanie słowników dostępnych w pakiecie biurowym OpenOffice. W celu instalacji nowego słownika należy:

  1. Pobrać wybrany słownik ze strony OpenOffice.org.
  2. Rozpakować pliki słownika i skopiować je do katalogu components/myspell, który znajduje się w katalogu instalacyjnym programu.
  3. Jeżeli nazwa słownika jest dwuczłonowa, np. de_DE należy zmienić "_" na "-", czyli de_DE.aff i de_DE.dic na de-DE.aff oraz de-DE.dic.
  4. Uruchomić program i cieszyć się sprawdzaniem pisowni.

Inne

Zapewne jest jeszcze wiele innych sposobów instalacji słowników jednak prawdopodobnie wszystkie one nie odbiegają od schematu dostarczenia do podkatalogu myspell w katalogu components w instalacyjnym katalogu programu plików słownika o nazwach pl-PL.aff i pl-PL.dic dla języka polskiego (względnie PL.aff oraz PL.dic dla Firefoksa i Thunderbirda nowszych od wersji 1.5.0.0).

Ciekawą właściwością systemów GNU/Linux jest możliwość tworzenia dowiązań (takich skrótów do plików jak dla programów w Windows); pozwalają one nie duplikować plików słownika (korzystać w wielu programach z fizycznie jednej kopii) i kilka innych ciekawych opcji. Aby wykonać dowiązanie symboliczne należy w terminalu wykonać polecenia podobne do podanych poniżej (linie zaczynające się od ### są komentarzem, nie należy ich wykonywać):

$ cd /usr/lib/thunderbird-1.5.0.4/components/myspell/
### zmiana katalogu na podkatalog myspell katalogu instalacyjnego programu

$ ln -s /usr/lib/openoffice.org2.0/share/dict/ooo/pl_PL.aff pl-PL.aff
$ ln -s /usr/lib/openoffice.org2.0/share/dict/ooo/pl_PL.dic pl-PL.dic
### utworzenie dowiązań symbolicznych do plików słownika OpenOffice,
### o nazwach z myślnikiem w nazwie, więcej informacji po wydaniu polecenia: ''man ln''

$ exit



Stefan Plewako 01:23, 5 cze 2006 (CDT)
Tę stronę ostatnio zmodyfikowano o 20:07, 8 gru 2006.

Osobiste:

Akcje:

:

Pomagają nam:

Przejdź do powiązanej strony

Nawigacja:

Stopka: